Lightify Color Spot Lights Not Actually Turning On

Not sure if this is device related or RM related. I have the rule shown below to turn on my Lightify Color Spot lights at sunset. I want this to go to 100% dimmer level and a specific color. The rule fires and all of the actions execute. My dashboard shows that the device is ON; however, the lights are not physically on. I can toggle the dashboard switch to OFF and back ON, and the lights physically turn on.
Do I need to have an action that first turns ON the switch? There is no ON action for dimmers that I can see, but I assumed that starting a dimmer action would suffice.


If you’re using the Advanced Zigbee RGB driver, try filling in the preferences on the device page (don’t leave as default) and hit save. If you’re using another driver, try hitting “configure” on the device page. For some reason the device is relaying back to the hub that it’s “on” if you’re saying the the state changes to “on” on the dashboard tile.
BTW, if you “pick a color”, it’s going to assign the brightness that belongs to that color (hue, sat, level), and override the level you set in the previous line of your rule.

I am using the Advanced Zigbee RGB Bulb Driver. The preferences were already set as shown below, so I'm not sure what I can do differently there. I did go ahead and "Save Preferences" again, and hit configure, though I think I've done that few times already.
I also changed the rule a bit to just set the color. We will see how this behaves. Thanks!


This is what mine are set to

1 Like

The new rule actions seemed to work better.
I am still getting some erratic behavior. I noticed that the extension I just installed are not following the color of the main strand of lights. When I get cyan on the main strand, the three extension lights are green. And the entire set will turn and back on a random times.

I am wondering of I need to reset the entire set to use the new extension properly.

Are the extensions plugged in backwards? That would cause it to be a different color.
If you’re talking about the garden spots, that would be the only explanation. The Zigbee unit on the main set doesn’t care how many extensions are attached, but I think the power supply is only rated for 2 extensions added to the main unit.

you cannot plug them in backwards.. more likely one of the wires is bad somewhere.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.