Light won't switch on

Hi Guys,

I've only just started with Hubitat and trying to get over the learning curve ( first time ever with smart home hub of any kind ).

I've set up the following Zigbee Swicth: with a Generic Zigbee Bulb driver ( Seems to work ok )

I've also had a go at the automations and created the following 2 simple rules:

  1. Lights on at 17.00 @ 25% brightness and turn off at 01.00:

  1. Increase brightness to 50% when motion is detected and turn off after 3 minutes:

Unfortunately it's not working as expected...

  1. Rule 1 ( Timer ) doesn't turn the light on, but
  2. Rule 2 ( motion ) seems to work well.

To keep it more interesting, the rule 2 will only work between the times described in rule 1.
If rule 1 is paused / deleted, the motion rule also stops working.

What point am I missing? I am sure it's simple, but I am struggling to figure it out somehow

Clicking the light "accent light switch" on the dashboard turns the light on and off as expected:

Thanks for any help!

have you tried using the same dimmer level (50) for both rules to make sure the 25 wasn't just too low for your bulb?


Also not sure I'd have wanted to use a bulb driver for a dimmer switch was there no driver more suitable?

Ok, gave it a go... no luck still.

I've tried some dimmer switch drivers, but got various results ( slow switching on / off ) or even not working at all.
When looking on the forum I came across people recommending to use the bulb hence the choice.

Would you suggest anything different? :slight_smile:

No I'm not familiar with this type of controller, just surprised me as I'd not have thought of trying a bulb driver for it

I am trying to replicate your rule and test on my Hue bulbs (driven via Hue bridge) to see if there is any bug in the rule

That's a shame...
Does the rule look ok to you though? Or have I got it wrong somewhere perhaps?

I just edited my previous post - trying it out

1 Like

Thank you so much! :slight_smile:

I can't see from your screenshots if you put anything in your Optional Restrictions field?

No, no restrictions added at all.

This worked for me. I think it's identical to your rule, can you double check?

NB "Ceiling lights" is a group of hue bulbs

Sometimes when a rule doesn't seem to work for no reason, deleting and creating again can fix it.

Seems exactly the same:

Would you be able to suggest any troubleshooting steps perhaps?

I just can't understand why the motion triggers the light without any issues, but the timer won't.

Already deleted and rebuilt - no movement there either.

Have you tried putting two times a couple of minutes apart, to run soon, just in case there is something it doesn't like about on and off times going over midnight... And making sure the bulbs are really off before they try to turn on, (just thinking of that thing where a fresh event isn't triggered unless there is an actual change of state) Though I have to say your rule looks fine you've certainly not made any errors in it

Yeah, tried the timer with all sorts of different times and still no luck.

Even when I totally delete the "motion rule" the lights will still not come on, yet I can switch them on and off perfectly fine from the dashboard.

At first I thought that perhaps the "turn off after 3 minutes" motion rule overrides the timer but even with this rule deleted the light still won't come on.

Sooo lost with it :rage:

You do have the correct time set on your hub, don't you?

On the screenshot you shared above, activate "Enable Logging", then change the starting time to 5 min in the future. Then open Logs page and watch/capture what happens in 5 min. If nothing happens, you may have a problem with the hub's time. It could just be the time zone that you set up. To validate that time is set correctly, go to Hub Details from Settings and make sure location coordinates are set correctly.

Lol we had the same thought at the same time :smiley:

1 Like

Yeah, time seems to be ok...

Is this likely to be a driver issues?
I just can't understand why it would be, when the light turns on off / dims perfectly fine from the dashboard and motion detection.

I've enabled the logs, and will post result in a few minutes.

Thank you for your help!

1 Like

Oh well time to hit the logs I guess. Turn on debug logging for your device as well as logging for the rule, IMHO

Amazingly that I beat you to it, my caffeine level hasn't kicked in to enable the troubleshooting skills, yet. Still working on my fist cup of coffee.

1 Like