Lifx Z Strip not working as expected

Hi,
I have 2 x lifx z strips and I have been using the built-in driver (LIFX Integration); for some reasons, both devices are detected as two different drivers:

  • LIFX Strip (LIFX Theatre)
  • LIFX Strip Legacy (Study-Lifx) => this one is not working.

The Study-Lifx was temporarily working (approx 15-30 minutes or so) and now it is not working (none of the actions are working; even though I can change the light setting through the lifx app); The log when I tried to turn on/off the device:

When I checked the device list, the Study-Lifx has created child devices too:

The question I have is, how do I go about removing these child devices and change it into "LIFX Strip" driver to make it working?

Thanks

The children are identical so switching the main driver shouldn’t hurt.

Thanks for your reply.
I just updated the 'parent' to LIFX Strip and pressed configure; the following are the outcome:

  • The child devices remain
  • The light is now responsive (Yay!)

Q: Is there a way to remove the child devices? as, the remove button is greyed out

Thanks



Update - the lifx z no longer responsive :frowning:

The following is the debug log, when I tried to turn on/off/configure/refresh

Download the Hubitat app