Lifx Light Strips, Hubitat, Ubiquiti, and IOTs

So I decided to try a Lifx strip for behind my TV replacing a RGBGenie ZV-1008 Zwave driver controller.

I currently have a Ubiquiti Dream Machine Pro with a private network, and a IOT network.
When trying to provision the Lifx controller it appears to provision fine if I use the private network but if I use the IOT network. I can see the led lights flash and it shows up as a Ubiquiti client but basically times out before finishing the device provision in the IOS app.

My Hubitat is currently in the IOT network so I would have to do a bunch more firewall fiddling to control the Lifx in the private network.

I have tried Lifx's suggestions of forgetting my networks on the phone and doing the 5x power recycles on the Lifex plug.

Has anybody else configured Lifex strips in an IOT network and did you have to do anything special?

I have a similar setup - with primary LAN, IOT network, UDM, LIFX...

I think when I set up my LIFX bulbs I connected my phone to the IOT network to do it... But I also have simple firewall rules to allow access from the primary LAN to IOT, but only established connections are allowed from IOT to LAN. So I can initiate from primary -> IOT, and IOT can respond, but IOT cannot initiate a connection into the primary LAN.

Can pull the rule specifics later when I'm home

Please do. Mine sounds the same but if I try to provision on the phone using the IOT network it seems to fail at the last step and says something went wrong.

I know it seems to be talking to it because the LEDs flash but it fails completion. I have doing a lot of forum searching but no real light bulb moment yet :slight_smile:

It does feel firewall related though. I am just not sure what it needs beyond its local vlan and the internet.

Yeah, if iphone and LIFX are both on the IOT network wifi during setup, the firewall shouldn't be relevant.

Is the bulb on the edge of your wifi range? I have one like this that is finicky and occasionally drops a packet

No I have a strong Wifi signal with multiple APs. As I said Ubiquiti does show it and I see the LEDs flash in the initial part of the IOT network provision but it eventually seems to hang and it times out.

If I put in the private network it provisions instantly.

I did do forgets on all the networks on my iPhone and just configured the IOT network but no difference.

Question - is your IOT configured for full network isolation (I think this is what it's called in the UniFi settings)? If so, that may be your issue - I think after connecting the bulb to wifi the app expects to communicate final setup over WiFi - full network isolation doesn't allow that, as each device is allowed only to reach the internet - kind of like guest wifi at a hotel.

That's certainly a good thought. It's been a while since I looked at the firewall rules and they certainly present different with the new UI since I installed them. They basically were a copy that's been floating around that I think most people use.

I don't see any toggle for "Full VLAN/Network Isolation" if there is one where would I see it?

I do allow specifically allow the IOT Vlan to talk to any IP address except where denied which is my private LAN.

I also know that my iPhone is talking to LifX because the lights initially blink so the question is what does LifX want to talk to. I can see it talking to the LifX cloud on the internet. I can see it talking back to my iPhone. I can also see it talking to the IOT DNS AKA

It works fine on my private lan AKA the 192.168.1.x subnet.

I don't see anything in the UDM management screens to trace specific traffic.

in firewall rules... look in the Internet section.. any rules for Internet Out for IoT?

Also try Turning off 5Ghz on your IOT wifi network and pairing your Lifx with 2.4Ghz. I think I had similar problem when my phone was on 5Ghz before.

1 Like

Not that I can see. My Ecobee, Flume, Rachio, Amazon, and other cloud devices on the IOT VLAN all work fine.

Tried that too! My IOT Wifi SSID is 2.4GHZ only. I turned off the 5GHZ earlier and restarted all the APs.

What is the firmware version on your APs?

All up to date:

UAP-AC-PRO in garage: 6.0.14
U6-LR on each side of house: 5.60.23

The Lifx module is about 15 feet from one of them with only 1 wall

Under Settings > Networks, select your IOT network and edit it. Under Advanced, there is a toggle for Device Isolation. Make sure this is off.

During setup, I believe your phone temporarily connects directly to the bulb via a temporary WiFi network, sends the intended wifi details, then reconnects to your wifi to finish.

Is this in the new or old interface? I looked under networks and wireless as well and don’t see Device Isolation?

In the new interface… look under your wifi SSID for client device isolation

Found it! Yes it’s been off throughout all this.

Lifx support :

Wi-Fi Settings Supported

  1. WiFi channels supported 1 through 11. WiFi channels 12, 13, and 14 are not supported.
  2. UDP and TCP port 56700 should not be blocked - you may need to contact your ISP about allowing access to this port.
  3. WPA/WPA2 or OPEN only. No support for WEP or WPS.
  4. 2.4Ghz channel should be set to 20Mhz bandwidth
  5. 2.4Ghz band b/g/n, 5Ghz not supported.

Thanks I think I have been compliant. Using Ubiquiti latest firmware

  1. I have the 5GHZ radio disabled for the IOT Wifi SSID. 2.4 GHZ Only
  2. It works for the Private LAN just not for the IOT VLAN so I don't think the ATT BGW320 is causing a problem.
  3. It's set to WPA Personal
  4. It does not even show channels above 11. The width is 20 for the 2.4GHZ radio
  5. I don't see any B/G/N options I think it just supports all of them.

The transmit power is set to Auto.

How about disable your private network Wifi and try adding your Lifx?