Life 360 NEVER updates

I am having a ton of problems with the Life 360 integration.

It only updates two ways: when it is installed, or when I go into the app and click DONE.

  1. It never updates automatically no matter how long I leave it.
  2. The Life 360 Refresh button does nothing (at least nothing obvious - certainly doesn't update the present/not present status on my sensors).

Anything I can do troubleshoot this?

Silly question
Are you sure that the refresh is doing nothing?
If you have a separate browser window, open to the logging page, and hit the refresh button it normally makes a couple of entries in the logs.


Also, you can only run one instance of this per account, so if you have it running on st you will have to remove it.

Good thought. When I hit the refresh button I get this in the log:

There you go!
The logging page is really useful sometimes :slight_smile:

Except that error helps me not at all. lol. :slight_smile:

If you go back into the L360 connector app does it show the correct login?
And show that this is ok?

(Although I’m not sure if that would throw the oauth error you are seeing it’s work a check)


Yes and yes. And if I click DONE it will update all my sensors - exactly once. Here is what the log shows when hitton DONE in the app:

Also, within the app there is an ‘enable debug logging’ switch (under options) is this switched on?

When you click done with the logging switched on does it show anything in the logs?

The log above is with debug logging ON.

Then a few seconds after that I get the expected member update data, which is when the sensors update the one time they do.

Normally oauth is set when the code is installed on the hub.
As we don’t have access to this code or setting for in-built apps I would suggest that maybe it didn’t install correctly
Have you tried uninstalling the app completely, reauthorising you account etc and trying again?

That would be my next troubleshooting step

BTW keep a logging window open at the same time as installing to try and ‘catch’ any installation errors that may not show any other time.

Edit: I would personally also reboot the hub after uninstall just to ‘clear the decks’ and clean everything out of memory before the reinstall


The only thing that looks interesting during install is that there is another OAuth error:

I guess I'll test some more tomorrow, and if still not working submit a support email.

1 Like

I've had to re-enter my info twice now. It's been good for the longest period now.
It's on the nice list this Christmas.

Why is that?

My plugin runs on multiple systems without issue using the same account.

Or are you stating that it won't work on more than one Hubitat system because of the Webhook you push to Life360 during the app setup for the enter/exit of places?

If it's won't work on more than 1 Hubitat install at a time then I understand it.

What we have observed is that their webhook only supports one endpoint. I cant speak for other integrations, but running the st integration with the same account as the running he integration won't work.

1 Like

Ok so it was what I thought. It's the webhook that's the issue not the auth and circle/member enumeration.

With that, yes same issue on other systems using the webhook as it can only point to a single end point... which BTW can be a load balancer or proxy :wink:

1 Like

I plan on working on this some more today... Still don't know what the problem is, though.

I did have Life 360 setup on ST, but uninstalled it before moving to HE and my ST hub is powered down and off the network now...

I'll try changing my password and see if that does anything.

Does your page look like this?

Twice a while ago my circle place and people blanked out even though the login was ok. It's been good lately.

Yes. Login shows OK, my circle name is there, my place name is there, and the people names are there.

We'll be leaving the house soon, so I'll get to test it in a few hours.

As a side test, I also setup an IFTTT applet to change a test present sensor in Hubitat when everyone leaves. If it works, I can at least use that as a workaround.

Ok sounds good then...
IFTTT was really slow when I tried it back in the day.