LG WebOS Thin Q

It looks like this question gets asked every few years. I want to change my lighting scene when the TV is on and revert when it's off and maybe turn the TV off on no motion.
I've tried this

It discovers the TV but I can't figure out how to "pair" it.

This can't be that complicated, what am I missing??

Thanks for your help

Just read another thread, apparently you need the pairing key, which seems unavailable. Funny I'm looking for a deal on a 65" C3.
How do you like your LG TV?

PS- someone smarter than me maybe able to sniff out the pairing key using wireshark

I bought a 55" C2 a couple months ago. It has a beautiful picture. The WebOS and Remote take some getting used to.
I did have some weird issues at first, like no sound when I turned it on, but if I turned it off and back on it would be ok.
The software over the next two weeks updated itself 3 or 4 times and it straightened out and works fine now.

I do wonder why no one has dug into to WebOS? I would think managing your lighting scenes in relation to the TV would be a no brainer.

I don't have any LG TVs, but I do have a Thinq-capable washer and dryer. Not sure if they use the same platform, but I've found the Hubitat Thinq integration to be lacking. The Home Assistant integration works much better. If you use Home Assistant, maybe look there for a start and then share the devices back to Hubitat with the Device Bridge App.

1 Like

I've already have too many hubs, hubitat, hue, ecowitt, blink, etc. Seems crazy to have another just to tell hubitat the TV is on.

This can't be that hard

Try this to get the code How to add an LG TV to Control4 using their secret installer menu #con... | TikTok

I need a translator!!

@rob17 Have you checked if the Devices were created (I just set this up on a "new" second Hubitat and it did say it had to be paired (I couldn't find any way to do that either), but the tv device was created and able to be controlled by Hubitat (volume up and down, sending notifications all worked) I checked this with the Hubitat I already had setup and the pairing key's are different and both work)

Sorry I didn't see your post earlier
The devices are setup but the commands do not work

Here's a snip from the after I execute a volume down

Download the Hubitat app