Leviton VRCS4 Device Driver

Actually, I'm not even familiar with the "enable child dimmers" switch -- where do you see this?

If you're using my app and driver (Leviton VRCZ4-M0Z Switch Mapper and Leviton VRCZ4-M0Z Zone Controller, respectively) with a VRCZ4, the switch-mapper app should just let you assign the four VRCZ4 switches directly to four devices (or groups of devices), which they will control without the need for any automation rules (and including dimmer functionality).

Does your switch-mapper configuration look something like this?

OK so THIS is embarrassing. But the info might be useful. When I included the VRCZ4 it defaulted to the Hubitat VRSC4 Z-wave controller driver. The "enable child dimmers" switch belongs to that. Once I used your driver, the switch mapper works as I imagine you intended. I tested on some dimming devices and the dim/bright buttons work. The one thing that threw me for a bit was that when I turn off a dimming device the LED on the paddle doesn't turn off until the switch ramps to off. A feature not a bug. BTW Yes my switch-mapper configuration looks like that. Thanks again.

1 Like

No need to be embarrassed -- had a feeling you might be using the VRCS4 driver instead.

Might need to reach out to the experts (@ogiewon, @mike.maxwell, @bcopeland, @bravenel, and @bobbyD) to see whether there's a path to having the hub auto-detect the VRCZ4 and offer my driver instead?

Sorry to ask a basic question. I have down loaded the driver and the switch mapper and I am ready to go for the VRCZ4, but I can not get it included. I have factory reset the VRCZ4, I hold buttons 1 and 3, all the buttons blink Amber, I tried to exclude it first, HE doesn't see the device. Then I tried to include it and it is not discovered. I'm sure it may be something simple, but I'm missing something. Thank you in advance..

Where do we find this switchmapper version, I am having issues with VRCS4 as well, not responding to button presses or anything.

I am new to hubitat and this was one of the first devices I was trying to get to function. Paired fine, but not responding to anything.

Here is the link I used to get the switch mapper for the VRCZ4 zone controller, looks like you need the VRCS4, scene controller, which is built in to HE, you just need to change the driver once you include it. App and driver porting to Hubitat

How did you get the VRCZ4 to include? how close was your HE hub?

It's been a while since I included my four VRCZ4s to my network, but I remember that one of the units closest to the hub gave me a fair bit of trouble (though I don't recall offhand how I finally resolved it).

Just recently I had to move my remaining Leviton Decora Z-Wave switches and Eaton dimmers across from Smartthings to HE, and I couldn't get any of them to include until I unplugged my HE and moved it to within a few feet of the switches -- then they all included effortlessly. (I discovered subsequently that those Levitons have a separate "network inclusion" mode that works well without needing to move the hub nearby, but I'm not sure the VRCx4 units support it.)

I think the unit might be bad, of course its the first one I started with. I was able to exclude it but not include it. I was able to exclude and include 2 other VRCZ4 controllers. I set up the buttons in the button controller, but the are not controlling the lights, and log as an off push. Still need to work with it. Any quick tips would be greatly appreciated.

Are you using both my VRCZ4 app and my VRCZ4 driver (Leviton VRCZ4-M0Z Switch Mapper and Leviton VRCZ4-M0Z Zone Controller , respectively)?

Per above, your hub will (by default) assign the official VRCS4 driver to your VRCZ4s, since it doesn't know about my driver -- but that won't allow my app to function. It sounds like you may be experiencing the same behavior as @etomami.

I mistakenly used the button controller. I was able to control the lights with the buttons using your app without issues, thanks! The dimming isn't working quite right. I set a button with 3 different dimmer switches, When I dim one right responds immediately, up and down without hesitation. The other lights goes full on then off, then they all go off. I tried it with a single light and had the same issue. Then all the z-wave lights in the house go off and I'm left in the dark... but I can turn them right back on again, I'm working out the quirks and my limited experience with the system thus far, the fix may be something simple.

Hm. Not sure what you mean by "mistakenly used the button controller", but maybe you want to share screenshots of your app and driver configurations?

I had first used the Button controller app that was built into HE, but the realized I needed to use the app your app. The problem I keep having is the dimming. I set 2 leviton z-wave dimmers to the first button. They go on and off fine, but it I try to dim them, One light will start to dim, I stop pressing the dim button. then both lights go to max. brightness, then dim all the way to off, come on again brighten then dim, then all the lights that are on the zwave network go out, as if it resets. After a minute or two. I can turn the lights on the network back on. I found that this happens on all the buttons if I try to dim.

Hmm...that's curious. You're using both my app and my driver?

I only have one Eaton z-wave dimmer (directly) on any of my VRCZ4s (everything else is Hue devices), but that dimmer dims perfectly from the VRCZ4.

Is it possible that you have those other z-wave dimmers linked to each other, and there's some sort of "tug of war" going on between devices? I did have an issue where one of my VRCZ4s was controlling a Hue group (of two Hue bulbs), and I also had an Eaton z~wave dimmer bound to the group, and when I'd dim the Eaton the bulbs (and the Eaton) would start fluctuating randomly (but all in sync). (This was back when I was still on Smartthings.) IIRC, it was something to do with tracking only one of the bulbs in the group, and I resolved it by taking the Hue group out of the equation and binding both dimmers directly to both bulbs.

What's on those two other dimmers? And have you tried it with only one?

The dimmers I'm using are Leviton VRI06-1LZ dimmers. The only link they have is in an automation that tuns them off at night using the rule engine with HE. I have tried only 1 light on the dimmer, it does the same hit time once it goes all the way to bright then again and they go off. The load on the lights are can lights.

Strange indeed. Have you enabled debug logging on all the involved devices and looked at the log stream when this happens?

I looked at the log, the dimmer switch is acting as an digital on & level to 99% then as a digital off. no actual dimming of the switch.

Given that the VRCZ4s themselves employ some vendor-specific (and kept-secret) command language, I wouldn't be surprised if your Leviton z-wave dimmers are similarly idiosyncratic.

I wonder what you see in the logs when you dim those Leviton units directly?

When dimmed directly, you get "level" and then the percentage.

Funny...I hadn't tried my own "VRCZ4<->z-wave dimmer" link since I completed my migration from Smartthings to HE -- and in fact, my dimming (on this device only) is also broken now. It seems to be acting like yours.

Have you seen anything like this?

I wonder if the latency improvement from Smartthings->HE (which is dramatically visible elsewhere) is affecting just these Z-wave comms? I'll be away for a few days, but I'll try to look into this when I'm back.

I have been experimenting. I took the VRCZ4 off HE and reestablished the Leviton zwave to see if I could see any differences. The the VRCZ4 driver offers on/off and a scene controller. If I used the scene controller selection for the button, I could not control the on off dimming turning on it always ramped to 100 percent. but I could dim properly after that. once I reset the button to on and it it always came on with the last dimming level, here is what the leviton installer driver interface looks like.

Download the Hubitat app