Leviton Switch Woes/Venting

I have about twenty five devices on my Hubitat C5. It's a mix of Zigbee bulbs and outlet switches, a Kasa power bar and three Leviton Z-wave switches (all on outdoor lights. I only bought two of them and Leviton sent me a third in a warranty claim) and one Leviton Z-wave dimmer (on a chandelier). I have had nothing but problems with the Leviton devices and am at a point where I'm just frustrated. I don't really want to throw away more cash, but I'm at a loss. All are set up as Generic Z-wave.

The dimmer, has got "stuck" in the on position and I've been forced to reset it/reinstall it a few times. I actually left it disconnected from the hub at one point for about six months when it worked as a switch but was just unresponsive thru the hub.

Two of the switches work without issue, but one (of course the most important one) is all over the place. It currently won't turn on via a Simple Automation Rule, but will turn off by one. If you ask Google to turn it on, you get a variety of response but mainly that it cannot do it yet then the light turns on anyway.

I understand that four devices probably isn't enough for Z-wave but it boggles my mind that a company expects a blind faith investment in a dozen devices (I've read that here in other threads) to provide a functioning environment. At least they work when you manually hit the physical switch.

So, I'm done with my rant. Any advice or suggestions?

Two words for you: Lutron Caseta. Not cheap, requires an extra hub. I have about 25 of them though and they are rock solid. One of the best automation decisions I have made.

1 Like

Yeah, I know that's really the "proper" solution. I really wish I had gone that way from the start.

1 Like

Make sure your Leviton switches and dimmers on on firmware 1.2 at a minimum. I have had no issues with my Leviton switches and dimmers since making sure they were all on 1.2, with the exception of the Hubitat driver not correctly reporting physical events (although the generic drivers work fine).

That number is probably from me. I don't know there is a real number here, it just seems like this is about how many repeating items it takes to make things stable.

Zwave is a mesh. So you need items to mesh with. If you only have 4, the chances of them having multiple connections to each other or the hub is very slim if not none. Up to a certain point, the more things you add, the better it is.

At this point with only 4 items, you can either find a way to strengthen the mesh (repeaters or additional switches) or ditch Zwave and go for something else. Unlike some on here, I have no issues (that I am aware of) with Zwave, other than I find it is slower than Zigbee for sensors.

I do like my Lutron stuff for reliability and the fabulous Picos. But the huge lack of device types (like every sensor type, bulbs, LED controllers, and relays) and the lack of features in their switches (no scenes, no double tap, no favorite button, etc) are a limitation. So I have a mix of Zwave, Zigbee and Lutron.

1 Like

I don't know what firmware I'm on. I updated the firmware when Leviton sent me a Z-wave stick during the last warranty service process. I don't own a stick and have no intentions of buying one to support these Leviton. It frustrates me because I have some really cheap, generic Zigbee outlets that are older and were half the price of these and have always worked; I shouldn't have to buy equipment to get a basic switch to work. Thanks for the suggestion tho. I was hoping for a hub-based suggestion.

There is a community firmware update tool for the C-5 called 'Z-Wave Firmware Updater' that you can use to check firmware version/apply updates.

1 Like

I'll look into this.

EDIT: I downloaded it and the Leviton DZ15S firmware 1.2 to my PC. I don't see a OTZ or HEX file in the zip to point the Updater too. Only an .EXE and lots of .DLL

EDIT #2: Found the github

So... After working for a year as a "Simple Automation Rule", it suddenly stopped turning on at dusk BUT would turn off by another rule at midnight. Updated the Simple Rules to version 1.2 and it didn't help. Yesterday, made a Rule Machine 5.1 rule and it turned on properly.

Download the Hubitat app