Leviton Decora Z-Wave network wide inclusion failure

I have three Leviton Decora DZ15S-1BZ Z-wave switches. I have successfully added two of them to my Hubitat Elevation. The third one is far enough away from the hub that I am relying on network wide inclusion mode (which Leviton explicitly claims is supported) of z-wave plus.

Almost immediately upon entering network wide inclusion mode, the status LED on the third switch blinks red three times. The documentation says this means that the adding process was not successful.

What do I do now? Is there some way to troubleshoot if the Hubitat is receiving any communication from this switch? Is the fact that the status LED blinks red almost immediately, as opposed to after some reasonable timeout period, indicative of some sort of error rather than a timeout?

For what it's worth, I am running version of the hub firmware, and have already tried a Z-wave repair.

Thank you in advance for any advice that you can offer!

I know this may sound stupid, but have you tried to exclude it first?
P.S. I love Levitons because you can see on teh switch if inclusion or exclusion has been successful, right away.

I'm not sure if this is the same thing, but I did do a factory reset on it as well as putting the HE into inclusion mode BEFORE the switch, and the combination of those two things worked. Note that the Leviton instructions specifically say to put the switch into inclusion mode first.

I was having the same issue and came across a post on amazon of all places that said they called Leviton about this and that they had left out a step to factory reset the Leviton Devices. I followed the directions below and all my problems melted away.

I will list the steps so if you have any problems may be this can help you.
1- Plug the item in a working outlet or skip this step if this is a switch/dimmer/outlet
2- Press the button for 15 seconds to be sure unit is factory reset. After the light blinks red let go.
3- Press button for 7 seconds or until you see amber light blinking.
4- While amber light is blinking press button once more. If all went fine you should see a blinking green light.
5- Device is ready to be discover. Open your app and add the device.


Not clear what you mean by button. The manual says top button. Nothing happens when I do that. Bottom button switches to flashing green but nothing else.