Leviton Decora Switch LED blinking red/yellow - what is this?

Has anyone ever seen this happen?

I have Leviton Decora switches successfully paired with my HE system and working fine. Then suddenly the switches don't respond to manual control, then I hear a "click" and then the LED constantly blinks red and yellow. But, it goes back to working, and can be controlled by Hubitat. And yet, the LED is blinking red and yellow like something is wrong.

I've seen this happen to at least 3 different switches now.

The only way to make this stop is if power is cut to the device, like during an unplanned black out.

Which model switch?

Leviton DZ15S Decora Smart Switch with Z-Wave Technology

Not good. Red/Amber flashing indicates the switch has factory reset itself.

1 Like

Which means, what exactly... the switch still works. It still receives Z-wave commands and works with my sensors. I've had 3 switches do this on me, but nothing else happened other than the annoying blinking. Does it mean they have to be replaced or are damaged in some way? Or that I have some kind of electrical problem?

I don't know, but I'd recommend talking to Leviton tech support. What's the quality of your electric supply (vis-a-vis voltage dips and spikes, and current surges)?

Many electronic items, like smart switches tend to be sensitive to power quality. If you don't have one already, I would recommend installing a whole home surge suppressor. They are inexpensive (<$200), easy to install, and provide decent protection against small surges.

We do have a whole home surge protector. I know that we lose power in my area 3-4 times a year. It's rather annoying that way, reminds me of the power grid in India sometimes. But I don't know what else to say about voltage dips/spikes/surges.

I've found Leviton tech support to be pretty useless in the past, and Hubitat forum quite the opposite, even when it's in regard to non-Hubitat stuff, LOL. But, OK, I guess since no one else knows I'll try giving them a call again.

I must have gotten lucky with my Leviton support experience. The first zwave switches I installed were Leviton Decora. Once I discovered Lutron I replaced everything else, but this one switch remained because I was too lazy to mess with it. I finally started having issues with it and I called Leviton. I have to say they were pretty good. The guy knew HE, and recommended a firmware upgrade to the switch. Oddly enough he offered to just send me a new switch for free. Since I was going to have to open up the box to replace the old Leviton with the new one, I decided to just chuck the last of my Levitons and replace it with Lutron. BTW if you need an extra Decora with updated firmware let me know :slight_smile:

1 Like

What FW version do you have on the unit?

The Factory Reset should only be activated when a user has pressed the button for 14+ seconds.
Devices resetting on their own is not normal.

There are 3 situations where a device could blink RED/AMBER.
Factory Reset, programming the load type (Dimmer), and Min/Max (Dimmer).

Do you you have an Leviton Travelers (Remotes) attached to this switch?

[quote="Wheat, post:10, topic:74006, full:true"]
What FW version do you have on the unit?[/quote]

It should be version 1.20. I recently went through a big to-do about getting every device updated using Leviton's instructions. I was able to confirm that every device was ultimately updated or already at 1.20.

I don't have that remote, no, and I didn't factory reset the device.

1 Like

How many DZ15S Switches do you have that are resetting?
Just getting more info.

Does the device reset when it is not included in a network?

I have roughly 50-60 of these and only 3 are doing this resetting thing.

I'm not sure how to answer the second question. The device is, strangely enough, still included in the network, despite having undergone what I am told is a self-reset. It's still responding to rules with motion sensors, for example, still responding to Alexa commands, etec.

Did you try factory resetting those 3 devices?

Honestly, I would just call Leviton Tech Support.
They will probably replace those 3 for you.

As a nerd, I would say try switching a working one with one that is having this issue.
If it follows the device, it's just bad. It it follows the location, then you might want to check the wiring.

My guess is it's prob the device.

One thing - if I factory reset a device, doesn't it lose its connection to the network?

1 Like

Yes, it does. If you have a hub, it only takes 20secs to include it back in.
That's up to you. If you get a unit replaced, you'd have to do that anyway.

Make sure you exclude each device before factory resetting it! Otherwise you will create a stranded node in the controller, which is a bugbear to get rid off on the Hubitat C-5!

I'm happy to note that, thanks to the community's guidance, I am now an expert in ghost node termination. :slight_smile: But the point is well-taken.

1 Like

I had one do that last week. I first tried a z-wave exclude.. couldn't remember the button sequence. Then hit find Z-Wave I think and it flipped back to green and has worked since. I then ran a z-wave repair. I'll try to better document the situation if it happens again.

2 Likes

Only reason I'm reluctant to exclude a device that is otherwise working is that, once included again, I have to go back and fix all the rules and groups and dashboards that were using it.

I wish Hubitat had a way of doing this automatically.

Can the Hubitat not "Remove Failed Node"?
That is a standard thing in ZWave.

Download the Hubitat app