Latest Firmware breaks Sonoff SNZB-03 Motion Sensor

I have several Sonoff SNZB-03 Motion sensors utilising the type "Generic Zigbee Motion Sensor (no temp)". All is fine with them, but now I've upgraded today to I can no longer add any of these Motion Sensors.

Although the device is found, it just gets stuck on the "Initailizing" stage. I've tried with several (5 so far) and they are all the same.

Please can someone help - I really don't want to have to go and buy alternative Motion Sensors.


1 Like

Try changing to Markus's custom driver.
Mine work well with it.
You can get the driver through HPM.
Search keyword Sonoff and you should see the driver.

How do I change the driver, before the device has even been added? I don't get as far as adding the device, in order for me to then go and select the "Type" of device it is.

Sorry if I'm misunderstanding your answer.


What does the rest of your Zigbee network look like: how many total devices, how many repeaters, and any smart bulbs (and if so, what kind)?

My fault. Should have picked up on that.
When you are in discovery mode and the device is found as you've shown above, try pushing and releasing the reset button a couple of times quickly. Don't hold it in so it resets the sensor.
This may work for.
Also try pairing it next to the hub to make sure no repeaters (hopefully) get involved in the pairing process.

Thanks - just tried that, didn't work!

Worse still - I've just realised none of the Sonoff SNZB-03 sensors are working now!

How do I go back to the previous firmware?

Actually - just worked out how to rollback :wink:

If rolling back helps, maybe it was just the reboot. Did you see any "Zigbee network offline" messages from your hub? (The notification/chat bubble in the upper right would indicate this.) That would be one problem, but then you wouldn't get the devices stuck in "Initializing," just not pairing at all. But it might (have) help(ed) regardless. If you feel daring, you could try the update again. :smiley:

I have several of these and can say that they work fine for me on the latest firmware--but I know that doesn't help you. So a related question: what is different about our setups? If you don't find anything else you've tried to help, then exploring what I suggested above may be helpful:

no. all of my snzb 3 s stopped working. and the hub was rebooted several times since. didnt help