Kwikset 916

I have two Kwikset 916 locks which open close / report to the C7 Hub / App. One will not show a status change in the app when locked from the outside, unlock to lock. It just shows a grey tile with a question mark. It does fully lock so that is not the issue. It just shows a question mark but if I just barely touch the turn-piece on the inside it then reports accurately as locked. I have tried reseting the door handling function, no help. The lock it self is one of the closer devices to the hub and has other devices and a repeater meshed to it so not what else can be the issue? It's more of a comfort issue confirming the position of the lock but a problem still. Any suggestions would be appreciated.


Is this looking at a dashboard tile or at the device itself? Assuming it's zwave and exhibits the same behavior for both you might post your zwave details page. Maybe something else is going on that is affecting the lock.

I would suspect the lock is not actually fully closing, even though it appears closed, if you can "close" it by jiggling the inside handle.

Try locking it from the outside with the door open, and see if it registers as "closed" then.

Also, check the log entry when this happens - I'd be willing to bet it's "jammed".

1 Like

So went thru the process and do not see a Jammed message, in fact it says it is Isn't Jammed which the entire message is odd. When I went thru and locked door from outside it locked as normal, the Check and Lock display alternated flashed for a bit then I unlocked and tried again with the door open and same results.

So while I do not know wha the odd message is it does not give me any type of failed message.

This looks a lot like a wildfire directive 7-12 issue.. IE your lock has a physical problem related to how it latches and locks into the jamb cutout and you aren't getting an electronic message due to a physical error. Something is out of kilter in the way the lock tongue interacts with the jamb.

If it's a wooden door you might try this. Get a marker pen and slather the lock tongue. Close the door and lock it, then unlock it and open it carefully immediately. I'm betting you'll find high areas where the ink has left a mark - and if you do file those areas down carefully until they're showing as unmarked. I'll bet when it's filed down the lock will show up as working - it looks very much like a physical interference issue that is just missing triggering the lock switch sensor enough so it's locking but not able to tell Hubitat.. Because the microswitch or whatever it is isn't firing..

For other doors, you might play around with the latch plate on the door jamb.. Free off the screws enough so there's movement and shut the door firmly and lock, then gently reopen and secure the plate without moving the plate from its new position...

I just have this idea it's an analog issue not an electronic one, and you might waste hours working on the wrong end of the system..

That "tell me what this means" message is pretty wild, and very un-Hubitat-like. What driver are you using for the lock?

1 Like

Yeah I thought it was odd, I like the comment β€œvery un-Hubitat-like" The Front Door which is the problem device is using Generic Z-Wave Lock as is the Garage Door Lock also a Kwikset 916 but funny part is I do not see the odd comment in the Garage Door logs. I will double check to make sure its not binding but had done that in the past so do not expect that to be the problem.


Any solution on this? I have two 916s, one works perfectly and the other does similar as to this thread. I did compare the two and see under Device- Data grid one has a device type 3 (one that works perfectly) and the other has a device type 1 (doesn't work exact). I was wondering if that is the issue and how to change it.

I have not identified a mechanical issue with the lock not fully latching and then not engaging the end switch to show it is indeed locked. I can confirm each and every time the door is actually locked so at this point I just learned to live with it and when its time to replace it will go with a different brand.

Bummer. I think my issue which is slightly different - notifications when locked/unlock and whom is doing the locking - that works on one perfectly and not on the other one. I’m going to post a new thread for visibility and if I get any relevant info I will respond here for you.