Konnected not sending events post vlan change

@nate if he is around, or any other experts.

I have 2 Konnected Pro boards. I am finally getting around to being a little more serious on security, and moving all my IOT to a separate VLAN. I moved the C7 and both Konnected boards to a new VLAN. They have static IPs managed by DHCP reservations. I changed the all three device reservations, and rebooted them. Confirmed they are all on the new VLAN with correct IP addresses. In Hubitat the Konnected boards appear fine, and show correct addresses. In the Konnected ios app, the boards appear correct. My hubitat logs the konnected app running discovery, etc. Tried just opening Konnected child apps and clicking "done". I even added a new zone, and can see the hubitat log pick it up. However, no events are being received on the hubitat from Konnected. So all my automations have stopped. I really don't want to blow it up and have to re-add all devices to the rules. I have tons of them. Anyone have any other items to try please?

I have no familiarity with Konnected but I did have to do some tweaking with other IP integrations when I separated my HA stuff ont its own VLAN. What are you using to manage VLANs? Could it be a port isolation setting? Or some sort of UDP discovery broadcast not getting to where it needs to be?

I am using all ubiquiti stuff. Both the C7 and Konnected boards are on the same VLAN, and I am really only blocking traffic from vlan to vlan. But that is a good call, I will go through all the settings again.

On a side note. I want to keep the iphones/computers on our main network and move the Apple TVs and Homepods over to the IOT VLAN. What type of hell I am signing up for to try to get bonjour working across LANs? (if you have done this)

I don't have Apple TV or HomePods so I can't comment specifically. My apple stuff all sits on my user VLAN since it's iPhones and Macs.

I remember when I moved my envisalink over to unifi I ended up having to disable LLDP and tweak some other settings, including shutting off spanning tree. I'm not sure why specifically but I can tell you it worked. Might be worth a look-see. The symptoms there were HE would establish a telnet connection to envisalink and it would "look" like it was working yet no events were getting back to HE. Sounds a bit like what you're experiencing. So what I do now is on the ethernet port to which the envisalink is connected I override the port profile with the following:

I also found this on reddit:

Thank you for your help. I will give that a try.

I had to do this not so long ago. Had to manually change the API Endpoint value on the Konnected board. Itโ€™s part of provisioning, and that only seems to happen during initial discovery.

Found useful information on provisioning the board here:

The endpoint value should look like:

The token can be found in Hubitat Konnected Application State.

You can verify the API Endpoint value by looking at the Konnected UI:

Thank you for the post. The API endpoint is off i can see. Possibly getting out of my comfort zone, I am not a developer. is this a config file you can change, or can you browse to the Konnected board to change it? Or do I need to create a HTTP PUT request and post it to the board? if so, can I just send it the new endpoint value, I will I need to make sure I include all my known devices as well?

You will have to do an HTTP PUT. You could try just sending the endpoint value. But if youโ€™re just using simple contact sensors then you might try this curl command:

curl -H 'Content-Type: application/json' -X PUT \
-d '{"endpoint_type":"rest",
  "dht_sensors":[]}' \