Kasa switches not detecting physical button presses

I migrated from the community app to the built in Kasa app and since then the physical presses of the switches are not detected. They were working with the community app.

I changed the poll rate from 30 minutes to 15 seconds and the switch press is still not detected within the 15 seconds. I can digitally turn the switch on and off and the automation I have based on the on off state work just fine.

The physical presses are also not appearing in the logging with the debug turned on but the digital activities are logged.

Physically pressing the Kasa switch and clicking the refresh button from the device page does update the state correctly

The device driver code is exactly the same as the current version of the community integration. However, things happen....

  • First, try doing a "Configure" command. If you migrated from a early version if the community app, this may be necessary and never hurts. (This is also a good idea if you ever encounter an issue.)
  • Set Poll Interval again.
  • Close then reopen the device's edit page (or refresh the browser's page).
  • Look at the variable states section of the page. Is the value of Poll Interval correct?
  • Scroll to the scheduled jobs section of the Device's edit page. There should be a job for poll. The Schedule column should similar like the below with the difference being that the "6" will be different. The "15" indicates the poll interval set in the Hubiverse. If it is, setPoll scheduled the job.
  • Test. If it does not work, get back. We will need to collect some data.

1 Like

I followed the steps you listed (including clicking on Configure multiple times) and the device is stuck at the 30 minute polling interval. The variable states section shows 30 minutes no matter what value I try to change it to and the scheduled details at the bottom of the device settings always shows a /30. Refreshing the screen does not change any of the display values.

I tried this on 2 different Kasa switches.

I also tried to reconfigure one of the Kasa dimmers as a "Generic Zigbee Dimmer" temporarily and then switching it back to the Kasa Dimmer hoping that it would trick Hubitat somehow into resetting some internal settings on the device. It still didn't change the outcome. The polling interval remains stuck at 30 minutes.

I also power cycled the devices just in case a full reset would clear some settings on the device but it's still stuck at the 30 minute poll interval

PM me a copy of the device's edit page.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.