Kasa smart plug $3.50

Good price on a kasa plug. @djgutheinz has an excellent integration for these

Also sengled Bluetooth bulb for 99 cents.

7 Likes

Awesome thanks, just ordered both! Can only get one of each bummer. I will have my wife order some when she gets home see if that works for a second set.

KASA bulb deal is sold out :frowning: . Just realized the Sengled bulb which replaces it is bluetooth only, guess I will test it out for 99 cents.

1 Like

Just remember that the TP-Link Kasa devices are not Zigbee or Z-wave devices, so it may be difficult integrating them with Hubitat. There is a community based integration, but I do not know how well it works. The plugs are cheap enough, so there is little risk.

They do work with Amazon Alexa. I had a couple of Kasa plugs that are now connecting dust in a drawer. I replaced them in Zigbee plugs that integrated easily with Hubitat.

It works awesome actually with active development. I use it for a few devices I had before I started doing ZWave. When I needed some outdoor plugs later the price on the Kasa could not be beat as well. Picked up this deal to add one more smart plug I need in my garage for my holiday lighting so it was perfect timing.

2 Likes

These were some of the first devices transferred to my hubitat hub using code I managed semi-port lol. @djgutheinz came along and made the official port of his integration and I have not looked back. I would say these devices are as reliable as they come. I can not trigger one for weeks, then give an alexa command and get very quick response.

2 Likes

The Kasa Integration warns: do not use Kasa Cloud devices.

The devices I have are older and work though the Kasa Cloud app.

Is there a listing of which Kasa devices which work with the integration?

I am in need of a power monitoring plug to monitor my gas dryer. All of my current Zigbee plugs lack power monitoring.

That is saying not to use the authors old Kasa Cloud specific Hubitat app. He discontinued the separate app and merged the features into a single app that can do LAN connections or Cloud.

I think there are only a few devices that Kasa "locked" into using the Cloud connection. All of my devices can work on the Kasa mobile app, cloud or local, and the Hubitat integration. Through the Hubitat integration I have gone in and selected "unbind" on my devices so that they no longer talk to the cloud, they can only be controlled locally and I can still use the Kasa App if I want to (locally only). I totally removed my credentials from the Hubitat app and unlinked Kasa from Alexa, so the devices are only controlled through Hubitat now via the local wifi connection.

1 Like

I received my Sengled RGB bulb last night and am using Node Red to mirror it to a virtual RGB bulb in HE. It works but is definitely NOT instant response to Pico button pushes. At this point, I am only turning it off, on, blue, red, etc.

I ordered a 2nd thru wife's account and they are going in each kids' rooms for fun so speed is not as important.

2 Likes

Glad it worked out for you.

I believe you can get a dot for 20 bucks using this method now as well

I was thinking of trying this same route. Did you find a pre-made palette for it? Or what did you use? Link if there is one please. I did a little searching and came up empty. I have not done any integrations with Node-Red yet but I do have it installed and setup.

I use this palette to interact with Alexa:

Ah I was looking for something that would connect straight to it via bluetooth. I will check that out, sounds more elegant than making a bunch of virtual devices and routines in Alexa. The routines feel so clunky to me. Might be able to replace my Ring doorbell routines with that as well.

I might have spoken too soon about the bulb. It pairs as "first light" and I changed its name today to something meaningful and now I can't control it with voice with any Echo device except thru the app on my phone. My phone and Echo Show can control it by pushing buttons. All of my other Echos tell me that they can't find a device named XYZ. UGH!!!!

EDIT: The other weird thing is that it still shows at "first light" in the Alexa pallette in Node Red.

I am noticing this also. I got two (had my wife order one) and I have "First light" and "Second light".
I renamed them both yesterday. I just tested voice commands from two different Alexa devices and it worked using the new name. NodeRed still is showing the old name. I am thinking it is something with a cache in NodeRed. Might need to re-initialize the login or something.

My wife and I each have Amazon accts and it bit me in the a$$ again. If the device is in my account, all of the devices work with voice commands. If the devices is currently in wife's account, then voice control doesn't work with all the devices. For the devices who weren't recognizing the bulb, all it took was "Alexa, switch to Stephen's account."

UUUUGGGGHHH!!!!

Download the Hubitat app