Kasa light strip latency issue

  • Making the switch from smartthings to Hubitat and so far things have been great. I’m not super tech Savvy but I try. I already had a lot of Zigbee lights and motions sensors and they seem to be working flawlessly. I’m currently having an issue with my Kasa KL430 lightstrip right now.
  • I Struggled understanding how to connect the device to hubitat at first but was able to add it by manually adding the IP address.
  • Was expecting it to work flawlessly like the others, but sadly that isn’t the case. I didn’t realize this lightstrip just used wifi (at least that is what I understand). Turning it off/on worked amazing on my smartthing hub, but there is a delay every time I try to do the same on the hubitat and need to repeatedly do it before something happens.
  • I’m trying to look though the articles here to find help with latency issues like this but haven’t found exactly what I’m looking for yet. Any ideas would be appreciated.

It is hard to determine why you have a latency. I have several of these and they are turning on/off instantly from Devices Details page without failure.

Based on details you've shared, it might be something going on within your network.

Interesting so you’re saying you have the same light strips that I have and have no issues?? Something that I did notice when I’m in my device details for the light strips was that if I used the “refresh” option before trying to turn them off/on in the device details, it works amazing and snappy. I also still have the lights technically linked to the smartthings hub so I’m not sure where the issue is coming from.

Removing smartthings from Kasa wasn’t it. The only thing I could think of is that I didn’t actually install the lightstrip driver. I have a C8 hub and I tried to add the lightstrip driver from the link, but it kept getting an error on line 15 even when I copied the whole thing. Ended up thinking it may not be Necessary but maybe it is. I could include an image?

Seems I was placing the driver code in the wrong place. Was able to install the lightstrip Kasa driver, but sadly turning the lights on and off doesn’t always work consistently enough.

The last thing I’m noticing is between the Kasa app and the hubitat app. When I press on or off, it sometimes works and then it doesn’t for some reason. Then I noticed the Kasa a brightness. I try to have the lights at 100% in the Kasa and and turning it off/on keeps it like that. When I do this in the hubitat app, it seems to make it 50% the first time even though I don’t see a visual change. I could try and repair the devices.

I had to check on the model I have, mine is the new model, KL420L5, but I don't think the experience would be any different. I suggest removing everything, then installing the Kasa Integration from Apps page. You don't have to install any drivers manually. The built-in app should do that for you.

I would suggest uninstalling, reading the instructions, and then reinstalling. You should not have to add the IP address on installation if you install through the integration app. That is there in case a person fails to follow instructions and does not set a DCHP reservation (static IP address) for the device.

Installation Instructions: HubitatActive/KasaDevices/Docs/Install.pdf at master · DaveGut/HubitatActive · GitHub

1 Like
  • So I did ended up removing the light strips from the Kasa integration. I also unpair/repaired the devices from the actual Kasa app and even changed the name of the light strips in the Kasa app. I also ended up just installing all 6 of the drivers shown in the instructions.
  • I only used the Kasa integration that was preinstalled and turned off the optional options for adding devices. This time I was able to find the light strips naturally with the instructions and it saw the name change that I did only from the Kasa app.
  • I thought that would do the trick, but it still isn’t working properly.
  • I suppose it isn’t a latency issue but more of the device not receiving the command to turn off/on for the first/second try. After that, the response time is very quick and what I would expect from the light strips.
  • All I can think of is to place them into debug mode to figure out what the Hubitat is seeing, but I’m stumped still.
    Edit: still unable to make light strips work properly and now I’m noticing my lights are turning off randomly when turning off/on light switch. Will sadly be switching back to smartthings.