Kasa built-in integration suddenly flakey

I recently added a Kasa KL400L5 RGB Strip light. It works great. No issues. The problem is that other Kasa bulbs have become extremely flaky. Some stopped working at all. Some take several minutes to respond. All have reserved IP addresses. I can't make sense of this. Not even sure where to go from here.

I have debug turned on and getting some interesting entries in the logs like this:
dev:24562023-06-30 12:54:22.738 PMwarnmethod configure of child device Post Light RGB Bulb ran for 128,284ms

app:25792023-06-30 12:54:22.735 PMwarnmethod updateConfigurations of app Kasa Integration ran for 128,280ms

app:25792023-06-30 12:54:22.722 PMinfoKasaInt-2.3.5-1: updateConfigurations: Updating App and device configurations

Any ideas? I'm so bummed because these bulbs have been rock solid since I added them. Worked great in the user integration version and were good in the built in integration too. Seemed to go to hell after adding that strip.

I have 19 Kasa devices including some plugs and strips that are only used at Christmas time so they are unplugged. But that's never caused an issue...


All of mine have been slow lately, but work. When I say slow I mean 1-3 seconds to turn on or off. Nothing extreme.

So one of my bulbs that is suddenly not working is giving me this error when I try to control it via the device page:
Living Room Floor Lamp-2.3.5-1: parseUdp: [error: error, reason: not LAN_TYPE_UDPCLIENT, respType: LAN_TYPE_UDPCLIENT_ERROR]

So I added the IP address manually and it works just fine. I'm sure is telling me something, but I'm not sure what. And of note, until the last day or two it was working great without the manual IP address.

It looks like the ip changed. Do you have reservations for all your kasa devices?

Start there and read the next few posts for some ideas.

All have reserved IP addresses
Yep, but I'm confirming that now. :wink:

I went ahead and hard coded IP addresses for all active Kasa devices.

Thanks FC2006. What I got out of that thread is:

  1. I'm not alone. Others have had Kasa devices suddenly stop working in recent weeks.
  2. Others also stumbled upon hard coding the IP addresses and it worked for them too.
  3. I could have instead "Selected the "scan devices" function in the app page to repopulate the preference fields."

Since I do have DHCP reservations for these devices and the IP addresses won't change, I think I'll just go with leaving it like that. It's quite disconcerting when devices that were rock solid stop working. The Kasa implementation was so good that I overcame my resistance to use WiFi instead of Z-Wave or Zigbee. This sudden issue shook my confidence in Kasa on Hubitat. I'll leave it alone for now unless @djgutheinz weighs in with a real reason to not do so.

I am working on it right now. Following are some important notes:

  • Built-In Integration. IF you are using the Built-In integration (vice community integration), I need to know this when seeing issues. There is a problem with the Built-In Integration for those who MIGRATED automatically from the Custom App. On reboot, the migrated child devices are orphaned from the app. (devices installed via the built-in app are not impacted).

    • To see if a device is orphaned, go to the bottom of the device's edit page and look for "Parent App". If not there, the device is orphaned. Known issues:
      • IP can no longer be updated from the application in the event of a comms error.
      • Configure command no longer works. (does not impact operation of device, just annoying).
      • Save Preferences sometimes fails.
    • I am working on a fix to this (the Manual IP address is one of the steps). Basically, removing all app dependencies from the driver. NOTE: I am in the same boat, but have intentionally NOT fixed the problem.
    • The true fix is to UNINSTALL and REINSTALL the integration (OUCH) or accept the issues until I can fully emancipate toe children from the parent.
  • Device IP. IF the Preference for Manual Device IP OR Manual PORT are blank, then the Device IP will reset to Blank on Save Preferences. Do not modify unless you have issues. (I will fix this to not update if the values are blank.) (@FriedCheese2006 )

  • Interface Slowness: Can not duplicate on my 28 devices. @scoob8000. Which integration (Community or Bulit-In? Comms type: LAN or Cloud?

    • If using Cloud, convert to LAN. (you may have to manually enter the IP address in Manual IP address field).
1 Like

I'm using Built-in Integration. FYI

Built in, and local. I did clean up the orphans and rebuilt them all a few months back. It's not really that bad, noticable but not a deal breaker.

I honestly feel like it was related to some other hub update. I started noticing this after some of the more recent firmware.

1 Like