I've broken Webcore

I am currently unable to open the Webcore dashboard.
I have just completed migrating from Smartthings to Hubitat. I think what has happened is that it is trying to load my Smartthings instance and as I deleted everything from my Smartthings account it no longer exists but Webcore doesn’t seem to realise this. Luckily I can still get to my Hubitat Webcore from the Webcore mobile app but in any web browser I just get an error stating “There was a problem loading the dashboard data. The data shown below may be outdated; please log out if this problem persists.” and then it just displays “\loading…” in the top left corner where the instance selection is. If I click this there are no other options so can’t just select the correct Hubitat instance. This is what makes me think that it is trying to load the incorrect instance.
I have logged off and back on and also cleared browser cache but don’t know what else to try.
How can I forcefully remove the old Smartthings instance without affecting access to my new Hubitat instance?
Thanks in advance.

This has become more critical now as I have now managed to lose access via the mobile app too.
Basically I swapped the instance to the orphaned smartthings one in the mobile app. I then logged out of that instance but when I come to log back in it loads the Smartthings dashboard but displays the error “There was a problem loading the dashboard data. The data shown below may be outdated; please log out if this problem persists.” and then automatically logs me out.
It seems that my profile is defaulting to the Smartthings dashboard, the last one I was logged into.
Is there anyway to change this default dashboard?
Please can someone help me.

OK, just messing around here and have managed to resolve it.
I had the option to "Use custom endpoints" selected within the Hubitat app and had configured this as the URL for the hub. It worked fine since I installed it on Monday but then just stopped this morning.
I have now disabled that setting and I have my access to my dashboard back.
So that begs the question what that setting actually does. Anyone know?

Am I understanding correctly when you said you "deleted everything" from your SmartThings account, that you also removed/uninstalled the webCoRE APP from SmartThings?

If that is the case I would try reinstalling webCoRE on SmartThings to see if you can get some control back. Once you gain control you can properly logout from the webCoRE dashboard.

All sorted now but thanks anyway.
I've added another update to my original post with details of what I'd done wrong and how I fixed it.

You should post this in the main webcore thread.

You can install your own WebCoRE dashboard server instance on your LAN; that removes the dependency on the cloud based WebCoRE server to create/edit your pistons (you'd navigate to the web server of your local dashboard instead of dasboard.webcore.co). In this case you would configure the "Use custom endpoints" settings with the addresses of your HE hub and the machine hosting the dashboard server.

Do you know of any instructions to do this posted anywhere?

Check here, a little bit of a read...


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.