Issues with Thermostat settings in RM Legacy

I've got some older Rule Machine Legacy routines (RM 4.0) that I've been using for a few years to control thermostat functions. The thermostat is an Ecobee 3 Lite using the built-in Ecobee Integration app. Today when I tried to update the thermostat settings in one of the rules, it would not accept the settings.
Specifically, I'm just trying to set the thermostat to auto:

But after I sent "auto", it just reverts back to no setting:

Things I've tried to resolve it:

  • Inserting a new action (same problem)
  • Verifying my Ecobee Integration login (no impact)
  • Rebooting the hub (no impact)
  • Upgrading the hub (went from to - no impact)
    Other clues:
  • I tried creating some thermostat actions in RM (5.1) with the same device, and the settings do stick there (works)

Short of recreating all my rules in 5.1, any idea what's going on with the RM Legacy thermostat settings?

That version of RM clearly is not up to date, as the Thermostat capability has changed since it came out. It's not really supported anymore. Having said that I will look to see if this one aspect can get an update.

Your best way forward is to rewrite this rule with Rule 5.1.

1 Like

I was under the impression we could stick with the legacy rule machine, just couldn't add new legacy rules. In my case, all I was trying to do was update a thermostat action.

Appreciate if the Thermostat device still functions for RM 4.0 -- I've got a lot of rules still in legacy, and many of them are inner dependent. All have been working fine until this issue popped up.


Download the Hubitat app