Issues with Minoston Ourdoor Plug after Hub Update

Ohh, this "Firmware Udate"

3 Likes

correct

Its updating now,
how often should this procedure be done?

The button will disappear once the update completes. This is a firmware update to the hubs Z-Wave Radio chipset firmware. These updates are very rare and only 1 or 2 others have happened in the past. The firmware update seems to have improved a lot of peoples meshes so :crossed_fingers:

I have the same outdoor plug - use it to control some landscape lighting and it seems to be working fine.

correction: apologies - turns out I have the actual Eva Logik dual plug in for that purpose - I had to double check. I do have the non-dimmer variety of the Minoston but it is not yet back in operation this year - use it + solenoid valve for some automated patio watering ...

1 Like

Thanks! I'll have to keep an eye out for that button if it pops back up.

Is your minoston listed under the Drivers list or are you using a generic driver?

the z-wave driver is updated, i dont really have any way to test it until sunset or untill 5am tomorrow, but i did try to use Alexa to turn on the patio lights. They turned on, but at like 1% power, it never did that before.
any ideas?
Here's the page for the Patio Lights, i see there's a Minimum Brightness set to 1%, is that my problem?


Possibly.. I've had some instances where turning off a dimmer (not your device) causes the dimmer to get set at a very low dimming level so then when I turn it on it again it's still at that low level. My work-around has been instead of doing a dimmer "on" command I use "set level 100"..

Yeah, i dont even want to use the dimmer function (dont think my led bulbs are dimmable), it was ramping the power up when it would turn on over the course of 1/4 second or so, didn't really think much of it, but didn't really see an option to just hit them with 100% power out the gate at sunset or when the motion sensor is triggered.

I set the minimum brightness to 99% (thats the highest) hopefully that fixes it

Edit:
here's the rule for turning on the lights at sunset, i just have it set to "ON" not a "set brightness", strange

1 Like

Yes, safe. Those are community developed Minoston drivers - another HE owner has graciously created (or adapted from another source, looks like they came from SmartThings) drivers for Minoston products.

If you want to to add the driver code to your system to use it w/your dimmer see instructions below.

Installing and applying a new driver

First you need to go to the Drivers Code section in the Advanced section of the HE menu.

image

Then click on the New Driver option in the upper right corner of that page:

This wil open a blank driver code page:

Open the link to the GitHub site that Minoston sent to you, and then click on the Raw button on the right hand side of the page at the top of the code section:
image

That will display just the code in a window:

Click anywhere in the window and press Ctrl-A to select all the text, and Ctrl-C to copy.

Then paste into the empty new driver code page back on Hubitat.

Then hit the Save button and the new driver will be saved to your hub.

Go to the Device page for your dimmer plug. Scroll down to the Device Information section and click in the *Type field and type "Minoston" (w/out quotes):

As you type an auto-search will bring up drivers w/"Minoston" in them. Select your new driver "Minoston Outdoor Dimmer (MP22ZD) and click on the Save Device button lower down.
image

Then scroll to the top of the page and hit the Configure button to complete the application of the change to your dimmer. Always hit Configure after chaning drivers.

That's it, you're now using a new driver.

2 Likes

i'm going to add it.
I tried to change the Minimum Brightness to 99% and that didn't work, hopefully the correct driver will fix it.

Thanks for giving those instructions. That was as clear as it gets!

I dont think the updated driver helped with the problem, but i did try playing with the "Set Level"
it was blank for Level* before, i set it to 100 now when i toggle it on/off it at least goes to full brightness.
image
Not really sure why it just got all wonky all of a sudden, but i'll know tonight at sunset if its fixed.

you can temporarily change the time to now, or simply click the run actions button on the rule

1 Like

You could just change the rule from turn "on" dimmer to set level - The dimmer should turn "on" when set level is set even if it's to the same level as it already is... if that makes any sense.

Then you'll likely never have an issue even if the dimmer level inadvertently gets set very low..

caveat: I don't actually use the Rule Manager apps so my knowledge is a little fuzzy in that area.

where's the Run Action button?

oh I thought it was in rule machine. Just change the time temporarily

I think i'm picking up what you are putting down :grinning:
i'll give this a try. What you are saying makes sense

1 Like

FWIW, I use the HE Generic Z-Wave Dimmer driver w/a Minoston indoor dimmer plug, and it seems to have been working well.

1 Like

I'll give the generic driver a try if this doesn't work.

1 Like

i changed the time and it looks like its working.

Who knows what the hell fixed it, but tis working now.

2 Likes

Maybe sometimes the off doesn't turn off all the way and causes the brightness level to get set at that point...:man_shrugging: Glad it's working though.

1 Like

Download the Hubitat app