Issues with Lutron switches and lighting rules

So i added some lutron caseta switches for hallway and kitchen. They seem to respond much faster than the zigbee smart bulbs but now I have a problem.

Using rule lighting to turn on lights when motion occurs and turn off after 3m of no motion (works). Especially in the kitchen i would like to override the off by using the lutron physical switch so in the rule i have don't turn off if the physical button has been pressed on. My problem is when i make the automation to turn on the lights with motion it makes the lutron device "turn on" and now the rule is disabled because it thinks I physically hit the on button. How do I get around this??

to throw something else out there, i noticed just now i can tell from the logs if the switch was turned on via digital (rule) or physical (press button)

Kitchen Lights was turned on [digital]
Kitchen Lights was set to 100% [physical]

Can this be leveraged somehow?

if not i guess i can go back to node-red and get it that way but was trying to have all my rules in hubitat now.

Add the switch to the means to turn off. Or add the switch to 'switches that determine lights are off'. Physical/digital is derived and potentially not reliable depending on how you control the lights. Hubitat marks any control that originates from Hubitat as digital and everything else as physical. If you have the lights hooked up to, for example, Apple Home or Alexa directly Hubitat will consider any commands from them as physical.

If i add the switch to 'switches that determine lights are off' my lights never turn off then because the lighting rule sets the lutron switch in hubitat to on (meaning it thinks i hit the switch)

I misread your use case. You'll need to use the physical vs digital activation, which may be unreliable depending on how you control the devices. Under Disable Turning Off upon these Events you can add the switch and choose physical only. Another way is to use Pico buttons to separate the logic from the switch.

Believe this is what your talking about doing? I hit the on switch and see it in the logs but the lights still turn off 3m after last motion. Might be missing something...

Turn on logging for the RL app and see if you can trace the progress/issues.

Try moving the physical only option to Disable Activation rather than Disable Turn Off. When you physically hit the switch, you do not want Room Lighting to turn on via the motion sensor since the light is already on.

dev:352024-07-10 09:15:31.599 AMinfoHall Motion 1 illuminance is 0 Lux

dev:752024-07-10 09:15:29.710 AMinfoHallway Lights was turned off [digital]

dev:742024-07-10 09:15:29.698 AMinforcvd: OUTPUT,2,1,0.00

app:272024-07-10 09:15:29.687 AMinfooff: Hallway Lights

app:272024-07-10 09:15:29.661 AMinfoMotion Stays time over

dev:452024-07-10 09:15:03.807 AMinfoTV Outlet power is 9W

app:272024-07-10 09:14:29.623 AMinfoAll motion inactive, scheduling off in 1 minute

app:272024-07-10 09:14:29.609 AMinfoTurn Off Event: 'Hall Motion 2' motion inactive

dev:362024-07-10 09:14:29.517 AMinfoHall Motion 2 is inactive

dev:752024-07-10 09:14:15.571 AMinfoHallway Lights was set to 100% [physical]

dev:742024-07-10 09:14:15.561 AMinforcvd: OUTPUT,2,1,100.00

dev:362024-07-10 09:14:07.634 AMinfoHall Motion 2 illuminance is 11 Lux

dev:752024-07-10 09:14:02.846 AMinfoHallway Lights was turned on [digital]

dev:742024-07-10 09:14:02.799 AMinforcvd: OUTPUT,2,1,80.00

app:272024-07-10 09:14:02.785 AMinfosetLevel: Hallway Lights, level: 80

app:272024-07-10 09:14:02.744 AMinfoActivating for Morning

app:272024-07-10 09:14:02.710 AMinfoActivation Event: 'Hall Motion 2' motion active

dev:362024-07-10 09:14:02.657 AMinfoHall Motion 2 is active

I did the hallway here as the switch is closer to my computer lol

Still turns the light off, i'm missing something

The logs indicate that Room Lighting (the light) was turned on via motion (Hubitat). You need to physically turn on the light before motion turns on Room Lighting.

I'd have to be the flash to do that lol. regardless of that I thought the setting of disable activation would stop that function then regardless of motion? Seems it just ignores it

It should stop activation only if Room Lighting is not already activated. Basically, you need the motion sensor in a place that allows you to manually turn on the switch before it can “see”’you; otherwise, you’ll need to figure out why the disable turning off is not working.

One work around is to use Rule Machine that controls a virtual switch based on digital/physical. Then use that virtual switch in Room Lighting instead of the physical option.

hmm, so unless hubitat staff checks this post i dont know of another way to troubleshoot the issue. i dont see a way to submit a ticket

I think one of the issues is that 'on' command is not sent if you push the on button while the lights are already on. All that is seen is a level change.

Here's a possibility:

Have your motion sensor turn the light on to 99%. If you have one of the older style Caséta dimmers the on button always comes on at 100%. So you should be able to use the turning off option "Prevent motion inactive from Turning Off after level change"

I actually have them come on at 80 then change to 20 after bedtime. I like the thinking but guess i'm already doing that. Think that's why it shows above in my screen capture 80 (100) because the switch changed it to 100 when I pressed on.

Then you should see if the option "Prevent motion inactive from Turning Off after level change" works. That's in the additional options in the Means to Turn Off. Basically, if it works, to override the motion sensor and only use manual control, you just need to hit the "on" button on the switch.

Note, going with the above, you'll also want to add the switch as a Means to Turn Off. This way Room Lighting turns off when you manually turn off the light and not get stuck in an Active state since motion would have turned on the light.