Issues trying to fade up hue bulbs

I'm trying to fade a hue bulb from 0 to 100 over 10 minutes.

In rule machine if I select "set dimmer level" it will only let me set the "with this fade (seconds)" to 100. Far short of 10 minutes.

I also tried "fade dimmer level over time" and while I see it showing in the logs ever time, it does not do anything most of the time. I got it to work once then I added another bulb to the list and it stopped working.

I have tried deleting the rule and redoing it at least two dozen times with different options to no success. I have turned the bulb on before starting the fade, I added a delay, I tried with multiple bulbs and several other things. I am so frustrated with this, what am I doing wrong?

I've used "fade dimmer level over time" in more than one rule and it's always worked for me. (Big help, I know.) I just tried a test with two bulbs, and that worked fine. Just for grins, I triggered the rule when one of the bulbs was on and one was off. The bulb that was on dimmed to match the other bulb, and then they faded up in unison.

Did you turn on the "Gradually Raise" slider when you set up the action? Have you tried fading over a shorter period of time while testing so that it's easier to see? Do the bulbs work well otherwise? Are you using Hue Bridge, or are the bulbs directly on your HE?

Just grasping at straws, here, because I can't get it to fail.

Yes, tried it up and down starting from 50% it still only worked a few times.

Yeah, tried many times.

As far as I can tell.

I am connected with the hue bridge, I can try connecting the bulbs directly and see what happens.

Are you trying to do it with a group, or individual bulbs?

Individual bulbs.

I was asking because I think it works better when using the bridge, so I wouldn’t suggest changing. As I said, I was grasping at straws.

I’ve used it with both groups and single bulbs and it worked.