Issues after flashing LZW31-SN

@bcopeland @Eric_Inovelli

Following up to my reply on the driver firmware topic where the first attempt at an update failed. I'm wondering if I have a faulty switch

I did a ZWave repair and rebooted the hub as suggested and also pulled the air gap on the switch, then tried again.

Things still didn't work (get version had no response either using the driver or the Z-Wave PC tool). I finally excluded the switch and factory reset and then was able to update with no problems during the update.

Except the switch isn't reporting reporting button press events or on/off state. I did a second factory reset and it then started reported the first couple of presses and then stopped again. It is reporting power though, and I get some data when I and responding to on/off commands from the hub. Also, the association groups look weird. My highest ID is 0x59, the switch I'm flashing. This is what I see in the state data:

actualAssociation4 : [AA, 00]
actualAssociation3 : [A5, 00]
actualAssociation2 : [AA, 00]
actualAssociation1 : [A8, 00]

I tried setting group 2 to control 2 other switches, but it only sets the desiredAssociation2 value

desiredAssociation2 : [0B, 09]

Not really sure where to go from here. I can control the lights from the wall, but I can't use it for scene control or rules since I never get events.

Any suggestions? Thanks much

That is strange .. It also appears it is part of your problem (actualAssociation1: A8, 00) neither of those is the hub (unless you have a really strange network)..

Association1 is where most of the magic happens.. And if the hub is not listed here you won't get much in the way of reporting.

I have no experience with inovelli's z-wave association tool.. Pinging @ericm as he wrote that tool and the driver in question here..

For each factory reset that you've done, did you first exclude the switch from Hubitat before doing the factory reset?


1 Like

Yeah, I actually tried setting that to [01] as well with the same results (only the desired value gets set).

The switch had been working fine (although at times slow as I said in the other thread) prior to the firmware update.

I may have resolved it. Using the association tool again, this time I told it to reset the association variables. Even though I was changing group 2, it also fixed group 1 to be [01] and now I'm getting events.

1 Like

I can't say I've seen random associations get set. Any idea how they may have got there? If you add or remove associations through the command boxes on the device page (and not through the Z-Wave association tool) then you need to hit the configure button or hit "Save Preferences" to send them. That is probably why the desired groups changed but not the actual.

@ericm The random associations were there after I updated the firmware. I had some issues initially getting it to update and had to exclude/factory reset/include before I could update it. Once it succeeded, the associations were there. I didn't notice initially, but I wasn't getting events from the device and eventually saw that.

I tried to set the associations both from the driver (I did click config) and from your association tool. It wasn't until I checked the box to reset the association variables that the change took.

I did update a second switch without problems though, so maybe the failed update left it in a weird state? I didn't think that was supposed to happen though.

Did you ever have a secondary controller on your network?

Yes, I have a z-stick I used to flash devices previously. It's ID is much lower than the random IDs in the associations though. I have no devices in that range.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.