Issue adding Hubitat to Homekit

I added the new application and hit OK when asked about compliance. However, I get a further notice about compliance after it tries to add Hubitat and does not load Hubitat as an accessory. I am using IOS 16.1.1

After scanning the QR code I get a OS popup that says “uncertified accessory” and I click add anyway.

Then I get a large HomeKit popup that says “unable to add accessory. Accessory is out of compliance”. I click OKbut nothing is added.

How do I get past what appears to be a secondary compliance issue?


What is your Home running? (mini or tv)

I have AppleTV and a bunch of HomePod minis.

Are they on the latest versions? (16.2 beta)

They are on the latest regular release. Not beta? Is that a requirement?

Shouldn't be but can't hurt to try. I'm currently running the beta and it works fine.

Just a word of caution; every device that isn’t on the beta, or will never be on 16.2, will lose access to Apple Home once you do the upgrade on the Home software. Also, being on the 16.2 beta is not a requirement.

My HomePod mini is on 16.1 same as my AppleTV. When I first start the add accessory process it shows the Hubitat as an available accessory. When I click it is when I get the first compliance notice. I select add anyway. Then I input the code from Hubitat. It spins for a while looking like it is adding, then I get the second out of compliance message.


I haven’t seen the second pop up. All I can think of is maybe try rebooting the Apple TV, etc. I’ve seen that fix other issues occasionally. Otherwise @gopher.ny is the man to let know.

Edit: another thought is what type of device are you trying to add? Lan and Wifi devices are not supported and button devices have been causing issues for some as well.

I took off the buttons and it loaded ok.

1 Like

I was so excited to add my Hubitat to my home that I couldn't wait until the next day to start making my integrations.
After adding one device at a time as suggested, and seeing that it was working great, I made a few changes and wanted to try to redo it to get it all well set up.
Note, it was already working great.
So I unpair my hub again (I had done it a few times before and it all went great), and tried to pair it again, but at this time an error appeared that had not appeared before.
"Unable to add accessory" - "Accessory is out of compliance"
I tried to reset the hub, reset the HomeKit, and reset my wifi. And nothing works.
So all my edits that were great disappeared and I can no longer add my hub to HomeKit.
Any suggestions?

Delete the he and the home in home kit, in the hubitat integration click unpair all device at the bottom. Reboot hubitat and see if it works now

1 Like

Are there any button controllers in the list of devices shared with HomeKit?
If yes, please try unchecking them in HomeKit app, and see if it works again.
Also, can you see if adding Hubitat integration to a new home in Home app works?

1 Like

I tried the new home and it didn't work.
My issue is that the integration stops working. So I have to delete and reinstall the hub in my homekit.
I open a new topic for this, because it is becoming very painful.