Is Z-Wave / Hubitat really suitable for real time lighting?

I mean this question in the nicest possible way and I'm not trying to be contentious. After 8 months using this system I just wondered if I was barking up the wrong tree with trying to control lights in real-time with Hubitat / Zwave?

I have a single hub system - using a variety of zwave devices. I use it to control all manner of things around the house - hot water, heating, ventilation etc and it's pretty faultless for everything that occurs in the background.

The issue I have is when trying to control anything requiring real time events - for example when pushing a button to turn lighting on and off. It seems to work fine 95% of the time with no lag or delays but every now and then it just lags horribly. Sometimes this can be a couple of seconds, sometimes it can be much longer.

I've tried so many things to make this better. I reboot the hub every night. Simple automation vs rule machine. I've worked through every article I can find on zwave mesh diagnostics. I've spent hours looking over the logs trying to diagnose what's going on and not really making much progress.

Have people managed to get Hubitat and Zwave to work 100% reliably with real-time events? I.e where lag is an unacceptable issue? If so, does anyone have any pointers to what I should be looking at?

It's a good question. Very much doable, with caveats and some care and feeding.

I use a two hub system with about 70 zwave devices and about the same number of zigbee devices running on my primary hub. I also have integrations with Lutron and Hue and a bunch of IP devices all on that primary hub. It cranks along with very little lag. Sub-1-second for almost all devices except for a few really chattty ones or ones at the edge of the network. There are a couple of Leviton plug-in outlets and Jabsco outlets that are slow but certainly manageable. When I have had issues with zwave devices in particular I've been able to track it down to the health of my zwave mesh. Can you post a screen shot of yours? If the slowdown is noticeable with other devices or you're experienceing slowness with the UI you may need to look at app and device resource utilization. But mesh first I think.

1 Like

I can't speak for everybody but a good number of us at some point have had frustrating issues of one sort or another so you are definitely not alone! No judgement here at all.. :wink:

My Z-wave switches have been extremely reliable for the most part for the last 2 years or so. Are you talking physical switching being slow meaning it's the device itself or some sort of rule based trigger - controlling other lights based on the switch event?

I have had slowness issues with dual Aeotec and Fibaro behind the switch relays and certain no-load switches in an N-Way configuration. Ended up using the "smart bulb"/scene controller capability of the switch and testing for button presses.


I should also have asked... what kind of button and what kind of device are you trying to control?


Thanks for the replies.

I'm using Fibaro Dimmer 2 devices as the main controller for lights. I chose these because they came with DIN mounting and I wanted the system to be as neat and logical as possible - all mounted in nice boxes (plastic) so it felt like a properly designed system and not retro-fitted. These were initially connected with security but after issues I removed them and re-added without authentication to see if that helped. I would be willing to replace these if absolutely needed but the house was wired with this design in mind so a centralised dimmer is necessary (and ideally DIN mounted to keep it tidy).

Up until now these have been controlled with push button switches connected back to S2 on the modules. I.e. the modules do both lighting and control. Generally I find this to be OK but over Christmas it became clear that guests (and my wife) just hate it. The lack of feedback when they press a switch means they often press twice or press the wrong button. Even with a small lag that means lights turning on and off again when it catches up. If it happens to be when the system is lagging hugely then it causes chaos as people just start hitting buttons to try and get it all to work.

I have recently purchased three Heltun touch panel switches. The aim is to give users feedback that the button has worked. When they press something they hear an audible click and the LED changes from red to blue. My hope is that this feedback will be enough to overcome the slight lag but during testing I am getting really poor results. Sometimes the lights change instantly, sometimes it's a few seconds, sometimes its 5-10 seconds. It's slightly complicated by the fact I am trying to change the LED on the other two panels when the first panel is clicked (so they stay synched) but even so I'm seeing terrible results.

I feel like this may be a zwave issue. I have kept my rule machine logic very tight and don't run a lot of additional apps. When it lags it seems to coincide with delays in the zwave logs. Zwave below (the missing device is an AeoTec USB controller which is off currently). The UI runs fast all the time and logging on the rule machine logic seems to be almost instant. It does seem to be the signal to the switches that lags but that is very hard to pinpoint exactly.

I guess I am at the stage where I don't want to spend too much more cash. The general automation stuff around the house is great - very handy for controlling humidity, watching for floods etc. I wonder if I just need to totally re-think the lighting - maybe swap that over to something dumber so that it just works how people expect it should.

Just glancing you have 5 or 6 ghost nodes. Y,ou don't need security on bulbs and sensors, and the S0 security on is likely causing some of your Problems.


When you say Ghost Nodes - I know about the Aeotec - 0x19 (025)

I'm not aware of any other ghost nodes on the network? There are several battery powered devices that only call home when needed (Flood Sensors, Mood Panels etc). These are all connected and work though.

Am I missing something?

EDIT: The S0 is only on the flood sensors which don't report unless there is water detected. I can swap them to unauthenticated if this is an issue.

nothing to add other than I only have one (old) zwave dimmer. It's instant.

I found having a few old zwave devices on my c7 caused the odd issue, so I dumped a few (oddly, for cloudless-wifi devices, which work ace).

That panel is nice (pushbutton) - do you have a link please ? Ta :slight_smile:

Your photos are gorgeous!

Anything without a route showing in your zwave details page is likely a ghost and can cause the issues you're describing. I would also switch those Fibaro flood sensors off s0... as others have suggested. That is actually relatively complex though... which is why I avoid Fibaro flood sensors :slight_smile: It requires a secondary controller, usually in the form of a zwave stick (your offline USB controller for instance), and some (free) software from Silicon Labs, the not-so-aptly named Simplicity Studio.

Not sure why RSSI and response time aren't populated... perhaps you just rebooted? Would be good to take a look at those in a day or two.


I didn't realise that those devices were a problem. They are sensors I have turned off temporarily because I wasn't ready to do anything special with them. I have turned on the ones I plan to use and have removed the ones I no longer need.

I have simplicity studio - it's how I managed to attach the Fibaro modules without authentication. I will re-add the Flood sensors without S0 when I get a chance (it's a right PITA). Once that is done I will remove the PC controller so that doesn't show up ghosted too.

I will give all this a try and let you know how it goes. Thanks again - very much appreciate the help.

Well let’s hope they were part of the problem :). That would be an easy fix. It’s usually worse when the ghost is really a ghost and not just an offline device.

I find resolving Zwave issues is kind of like peeling the proverbial onion. You resolve one issue, then move onto the next, and the next… and eventually you end up in tears before you finally fix the problem :slight_smile:

Also you may have to give it a day or two to adjust to all the changes so if you don’t see immediate results be patient. (Odd advice coming from me, the world’s least patient person.)

When the response time field starts to populate take a look and see if you have any outliers.


I have found that the combination of Lutron Caseta switches and dimmers and Zigbee sensors (both motion and contact) seem to be very responsive.

I have experienced issues with Z-wave devices in bathrooms with mirrors, water piping, heating ducts, etc. Thus, I do not recommend Z-wave for that type of environment.

Quick update. I removed all the ghost nodes. I also removed the PC controller and USB stick just in case that was an issue. I then removed all but the most critical apps (removed dashboards, Echo integration etc). I am left with just rule machine, simple automation rules, groups and scenes and the Hue integration.

Yesterday was a nightmare - nothing seemed to work properly. I guess this may have been due to all the changes but my rules were just falling over left right and centre, devices were not responding or responding 30-40 seconds later.

This morning things are working but still occasional 4-5 second delays on the switches responding. I guess it could be the Heltun switches themselves but I have tried about 4 or 5 ways to produce the logic I want and none of them seem to give consistent results (I am a coder by trade so it's not like I don't understand logic).

I think I am about out of steam for this. Considering either just replacing all the bulbs with Hue bulbs (easiest as it requires no wiring changes but expensive as we have around 30 bulbs) or re-wire it all with a non automated lighting system (most work as it requires re-wiring the consumer unit but probably cheaper).

I've just had an idea. It solves the lag issue, is cheap to implement and means very little re-wiring.

I am going to change my push button switches to S1 rather than S2 on the fibaro modules. S2 sends a command to the hub which then activates a scene so that multiple circuits can be activated and deactivated at once. S1 directly controls the module - turning it off and on.

It's not perfect, as it means the buttons are controlling individual lighting circuits rather than scenes, but the control is instant, works without the hub and does not rely on any kind of automations or zwave messages. It's therefore very fast and reliable.

Also means I can still use a mood panel if I want. People are more forgiving of delays when setting moods. It's the day to day on and off that annoys everyone.

P.S 3 x Heltun 4 Button Touch Panel switches on eBay if anyone is looking.

Just a random thought. I like how neat your DIN mounted Fibaro modules are. However, that doesn't make for a mesh that is well distributed spatially. I also wonder if there is some degree of interference with all those z-wave modules in a row.

My experience is similar to yours...after countless data and looking through trends, here it is with a C-7

Always Instant:

  • Zigbee, Hue, LAN devices, anything non-Z Wave...doesn't matter whether it's in a rule or not
  • Z-Wave Outbound: any single device control through either the Device interface or dashboard (not through a rule)
  • Z-Wave Inbound: any single device, the hub always processes it

Not always instant, but 99% reliable:

  • Z-Wave Groups: With metering enabled, 75 ms delay

95% instant, but occasional delays of 1 to 5 seconds...or never:

  • Z-Wave Outbound: from ANY app
  • Z-Wave Outbound: trying to control multiple sequential Z-Wave devices

What was a big help for me was adding Z-Wave devices into a group and turning on metering with a 75 ms delay (although I think I am going to increase this delay to 100 ms).

So, my guess is that there is an inherent issue with the 700 series Z-Wave chip in the C-7. I am also an engineer, and my experience when something works reliable "most" of the time is that you have a firmware/software issue that needs to be resolved.

Disclaimer 1: "Instant" is roughly 100 ms to 300 ms according to the logs.
Disclaimer 2: Same device locations as earlier SmartThings implementation, and NEVER had these issues with SmartThings (although I'm not going back - hehe)

My general control strategy has been:

  • Zigbee: for sensors (motion, leak, etc)
  • Z-Wave: lighting and door control
  • Zigbee/Hue: pretty lights

This way, I don't have to worry about "chatty" Z-Wave sensors overloading a mesh.


KSGNow - This is exactly what I am seeing. If I sit on a device and turn it on and off manually it's instant - every single time without fail. Incoming zwave is generally instant and I can again sit pressing buttons all day long. The second I try to control multiple devices at the same time (or sequentially) it all falls over. I've tried several types of logic; rule machine, groups etc and get the same results so I think it is a low level issue.

I must admit - I have never tried the metering (I didn't actually know what that did).

I have swapped all the circuits to S1 and I am much happier with the result. Button presses are instant, no popcorning and it works every time without fail. I probably should have done this before but I was totally hung up on wanting to use scenes and didn't think of this before now.

1 Like

I'm facing similar issues. My 700 series UZB has arrived, I'm just finishing up another job before going through and changing S2 devices over to "regular" security.

However, after reading a bunch in the forum, and knowing how much I've messed around creating/deleting rules, etc I suspect I may have some database corruption as well. Once I've got everything squared away as best I can get it, I'm going to back up and then nuke and pave to start "fresh" from the backup. I've read more than a few posts talking about success after doing this.

Don't fear a Soft Reset. It takes just minutes.

1 Like

Tried that, some improvement, but the underlying problems persist.