Is WEMO just not working anymore?

I have used the jason0x43-wemo_connect.groovy for 12 devices for quite awhile now. Not sure if updates on it or hubitat caused it, but it no longer finds most of them. I try over and over and it finds 3-4 at best. Sometimes it seems to combine them as one unit in the list.

Looking through messages here, I haven't seen much posted recently, and some of the older posts seemed to indicate problems never resolved. Has this app just died with the almost year old update?
Thanks for any help or insight on this!

When was the last time you opened the Wemo app and made sure they were all updated.

About a year ago I had a string of blips with my two wemos. They needed updates and I may have restarted of my wifi network and it has been stable sense.

1 Like

@mavrrick58 - 5 minutes ago. It hasn't worked for a couple weeks now, so I am using the wemo app as my only way to control them.

Glad to hear someone has it working though. Are you using the latest versions? Thanks!

Looks like I installed it in 2020.. Code says it was last updated on 2019-07-23, 23:29:52

Thanks! I had found a newer version and updated recently (should have kept better notes) and maybe that is the problem the latest is dated: Last updated: 2021-03-21, 17:07:01-0400

Maybe I can roll back to an earlier version. At least this give me a path to try. Thanks Again!

Update: So far, I can't see a way to pull the older code :frowning:

Go on GitHub. Pick each file that you need individually (the app and the drivers). Click on History for that file. And then download the older version .... (see example below):

Personally, I don't know if this will solve the issue you've run into. I just wanted to let you know that it is pretty easy to download older commits in a GitHub repository.

Just out of curiosity what devices don you have. Plugs, switches ect.

@mavrrick58 I have plugs, light switches and dimmers. Oddly of the 3-4 that it still detects there tends to be one of each type found.

@aaiyar Thanks for the reminder on history.

@aaiyar Thanks again for the reminder of the location button.

I rolled back one version and the problem was resolved.

@mavrrick58 Thanks for your responses. Based on my experience I would advise not updating beyond the version marked: Last updated: 2021-02-24, 21:14:00-0500
Currently there is one later than that apparently caused the issue.

For anybody else that this might help. I had also updated the drivers code. But, only the app code needed to be rolled back to get things to work. So, the latest drivers seem fine.

1 Like

My wemo devices stopped working a few days ago. Works fine from the wemo phone app and not firmware updates available.

@mattsmc As I posted I had to roll back the code and then they appeared again.

@edfenner downgraded the app code, but still having issues.

Did you downgrade any of the drivers?

I have these:

  • WeMo Connect
  • Author: Jason Cheatham
  • Last updated: 2021-02-24, 21:14:00-0500

  • WeMo Dimmer driver
  • Author: Jason Cheatham
  • Last updated: 2021-03-21, 17:11:06-0400

  • WeMo Switch driver
  • Author: Jason Cheatham
  • Last updated: 2021-03-21, 17:08:44-0400

Hope that is useful.

1 Like

Ok my problem was two-fold... this update as described above and that I needed to re-add by IP address and port as the detection is not working on my network. Once I ran nmap on the target IP I used that to test the ports.

(yes I had deleted everything in an attempt to fix this, if I had just downgraded the app version I probably would have saved myself some trouble)

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.