Is it possible using Rule Machine or Echo Speaks?

Hi, I use Echo Speaks - still the version 3 - and it works very well, but I was trying to make a rule using Rule Machine where:

  1. A trigger - motion - make an Echo Dot say "Do you want to watch something?" (it is the simple step, I already done it)
  2. I would like to say, b.e., "Yes, Netflix" or some other options, like Amazon Prime or Plex, and my answer would trigger the specific rule - I already have several, one to each of my sources.

My question is if is possible to send this command to an Echo without use its "wake word", Alexa.

I was thinking about something like a natural conversation: I enter the room and a motion sensor trigger the rule , making Alexa asks if I want to watch something and a simple answer "Yes, variable" trigger the correct rule.

And sorry, I don't know much about RM, so detailed answers are extremely welcome!

Thanks in advance.

No as I understand Alexa.
To "enable" her/it you can have "Alexa" or "Echo" there are no other options. In theory the device (Alexa/Echo) is deaf to all conversation except for whichever of the two trigger words you set in the Alexa App (on your phone)

Yep, exactly what I imagined. But I was thinking if there was a way, through Echo Speaks, to send a command to the Echo "wake up" in a discrete way, like some IR codes...

It actually is possible, sort of. I use a technique with Echo speaks to answer specific questions, but it's not natural as you wanted.

For instance in my goodnight routine, if I have not turned on the ceiling fan, my goodnight routine through my bedroom echo device will ask, "Would you like me to turn on the fan?". I am actually doing this in webcore, but I think it could be done in RM as well.

I then can say "Alexa, yes please" and the routine will turn on the fan. You have to say Alexa each time

Basically I have two virtual switches one for yes and one for no. Although I really never use the no switch I just assume if the yes switch does not get set then it's no, makes things simpler.

You can't say yes or no, because those are reserved words so it has to be something like "Alexa, yes please" or "Alexa, affirmative". So again not too natural.

In the case you spoke about you could have your device go down the list of things to watch. i.e "Would you like to watch netflix?" If you answer no then the next and so on.

1 Like

Thanks, @terminal3! I saw a walkthrough to make it using WebCore, and that was the inspiration to try it using RM. I found it to be a very clever approach.

The main question is that the question asked by Alexa will be an "open" question, with my answer containing a variable that would allow me to choose between several sources, but this is really the approach.

Thanks for your suggestion!

Is this the Webcore method you were taking about?

1 Like

According to Amazon, the Alexa devices cannot listen unless/until the wake word is detected:

1 Like

Thanks a lot @tony.fleisher

Exactly @mebejedi! My idea was go further, but apparently Alexa's limitations do not allow...

Hi I'm new to using Hubitat and I'm trying to get echo speaks actions, particularly play (a song), in rule machine in order to leverage the more complex logic available. in RM 4.0 However, it does not seem its visible or I may be missing something.

I am not sure what the "playtrack" action expects for arguments but you should be able to do it via "run custom action" as illustrated...

Tried that as well but echo was unable to either find the track/song or was getting errors in the log for mismatch exceptions.

Only using echo speaks is it actually able to recognize what I pass through as a parameter whereas using the custom command Play()/playtrack()/etc. does it fail.

Maybe I'm not understanding the question. When you say "echo speaks actions" what specifically do you mean? It might make it easier for for me to get my head wrapped around a screen shot if you can post one.

I tried using the SearchAmazonMusic function too and it seemed to work fine... again using Echo Speaks.

Yeah I was trying to pass through a playlist but adding Playlist, XXX made it work as expected. Thanks!

1 Like