Iris V3 Keypad - "On" = Arm Night instead of Arm Away?

Hi All, I've had an Iris V3 Keypad for a few years, and it's always worked well, but since upgrading to a C8 late last year, (worked fine on my c7), pressing "On" is now Arming Night node.

I thought my cleaner was accidentally pressing "Partial" when she left, but this has happened multiple times now, and she's confirmed she is definitely pressing "On".

Any idea how to fix this? Mode Manager doesn't recognise the "buttons" on the keypad and the driver only has an option to configure "Partial".

I don't know how to fix, outside of saying just get Nyckelharpa App by ArnB. You'll ask yourself how you lived without it.

1 Like

I’ve never heard of it. I’ll go look.

It's incredible. I stopped using HSM until I found it. @arnb did a fantastic job


It looks great, but I don't see anywhere where it solves my issue with the keypad "on" button setting night mode?

The Partial set function doesn't even seem to work anymore?

and I've double-checked HSM - there's no option to say what the on button does, only partial:

If you look at the Location Events under the Logs tab what value is showing for the hsmSetArm events?

The following:

as you can see, it's commanding armNight instead of armAway. Im not even sure how that is possible when you cant configure the "On" button.

Sounds like the driver has changed. Is this a built-in driver or a community one?

I’m using the official Hubitat driver. I’m wondering if I need to factory reset it and see if pairing it to the c8 resolved the issue.

1 Like

Use the "mode fix" section and make sure you have loaded the centralitex driver for the keypad, not the HE driver


Nyckelharpa works like a dream. I've been using it since my days on Smartthings. Arn did a great job. It's one of the few apps I haven't had to make any changes to in years.


This didnt work. :frowning:

@bravenel @bcopeland @bobbyD gents, has something changed on the c8 version of the Iris v3 driver? I never had this issue on my c7 - that said, something could have changed last year and we just didnt use the function then to notice.

As mentioned above, the "Set Partial Function" option in the driver looks broken too?