Iris v3 iL07_1 motion sensors getting stuck at "Initializing" when pairing

I have three of the iL07_1 Iris v3 motion sensors which have been on Hubitat's compatibility list for some years. When I try to join them, they get recognized, but I can't get past initializing. I've tried shutting the hub down and doing a power cycle. I've tried restarting the Zigbee pairing button after the 60 seconds have run. I've tried removing the batteries and resetting the sensors with the button on the side held down until the light turns red. Each time, the sensors seem to indicate they have joined (green triple blink), but I can't get past initialization. I'm pairing them within an inch of the hub. I'm on a C-7 running
Any suggestions?

Are you sure they are reset? Reset them using the procedure I outlined in this post:

And I can confirm that they definitely work with the latest platform on both a C-7 and a C-5. Also, I paired one recently to a C-7 (within the last 2 weeks).


I can confirm they do work, and I have also paired some recently. And re-paired about 10 of them when migrating hubs.

Not that this has anything to do with why these aren't working for you, but you are behind a bit on updates.

1 Like

Also, if it reassures you any, someone else had trouble pairing them recently, but the issue was resolved by resetting them properly, followed by re-pairing them very close to the C-7 and leaving them in place for 2-5 minutes.

1 Like

That also is one thing I had to do on occasion, glad you remembered to mention it. Some sensors sometimes did nothing for a couple minutes. Other sensors work fine right off the bat.

1 Like

Thanks all for the help - still no go.
aaiyar: I've tried the reset procedure you've described. I start clicking rapidly as soon as the red light shows. While I'm still clicking, it goes to lilac. I'm not sure how long it is supposed to stay solid lilac before blinking lilac, but it appears to me that the solid light doesn't last long -- it really just looks like part of the blinking pattern. After 5-6 lilac blinks, I then get 3 green blinks (even if the hub is shut down). Should I still get the green light if I have successfully reset it and there is no hub powered up to pair with? Maybe I'm just failing to reset them.
neonturbo: Agreed that I am behind on updates. I'm new to Hubitat (from Iris to SystronicsRF to here). I figured I'd stay with the build I started with until I know more about the system (rather than mess with the usually inevitable kinks in a new build). However, if anyone thinks an update might solve this problem?

Doubtful. The only times this has ever happened to me it was due to repeaters, either bad ones or a lack of. If you have a bunch of sensors and Sengled bulbs, but no repeating devices like Zigbee outlets or switches, you could run into the 32 device limit.

I just got out a never used sensor and tried it out.

I started the pairing on Hubitat, pulled the tape from the battery door, and it took a few seconds, but it did join fine.

I removed it from the hub, did a reset (Pull battery, hold button while installing battery, and so on) and let it sit blinking blue for a few minutes.

I then did a battery pull, put the hub into pairing mode, and reinstalled the battery. It found the sensor fine again.

I am probably at least 25 feet away from the hub when doing this. Not sure why you cannot get it to pair?

I currently have five Iris Gen 2 smart plugs (3210-L) distributed around the house. Since I'm pairing them within inches of the hub, I wouldn't think repeaters would be an issue.

That may be a clue to my problem. Mine won't continue to blink blue, even if the hub is disconnected. Instead, they go to a triple green blink after blinking blue (lilac) 5-6 times. Yours blink blue until you put your hub in pairing mode?

Yes. I think they time out after a while, but they stayed blinking for well over 5 minutes before I decided to try pairing again.

The other thing you might try if you haven't is to leave the battery out for 10 minutes or so before trying the reset, and leave the battery out again after the reset.

They are paired now. I took them outside away from any interference and they reset without going to the green blinking lights. What I don't know is which of my hubs was causing the problem. I have the Hubitat hub and a Rasberry Pi that is set up as my SystronicsRF hub. When I had my problems yesterday, the SRF hub was NOT in join mode, the Hubitat hub was. Today, I disconnected the SRF hub before bringing the sensors back inside. The Hubitat hub was in join mode, but well past the 60 time frame. Nevertheless, as I approached the Hubitat hub with each sensor that had been reset outside, they completed their pairing process.
Thank you for all who offered suggestions.
As a newbee to Hubitat, I have a lot to learn.



1 Like

If that's zigbee, make sure it isn't using the same channel.

1 Like