Iris v2 Motion sensor-unexpected behavior

I have been using these little guys for over two years. All of them have reliably detected motion and then reported inactive about 30 seconds after motion stops. The other day, I installed the first one from one of my Ebay lot purchases, and found that it reports inactive about 6-10 seconds after motion stops. I can think of a couple automations I have that could benefit from faster inactive reporting. So, I'm wondering if anyone is aware of some sort of hack that may have been performed on it in its past life?

Logs attached show four "around the corner hand waves" then standing in front of the sensor for about 20 seconds.

this isn't normal, nor is it configurable, it's likely old device firmware or test firmware on a device that escaped from someones lab...


Mike is, as usual, probably right, but I guess this is worth asking, too: is your battery new? Low batteries on these can cause the sensor to send spurious motion events, so if you haven't tried a new battery, that might be another idea. Definitely unlikely if all your motion active events are "real," since it seems like it's working fine and just reporting no motion earlier than any of the others, but who knows. (Some sensors have a "test mode" that allow you to make them do this--likely Centralite did in at least their development too. I'm assuming you've also reset the senor by holding the button as you insert the battery, not that this should matter if it's not configurable...)

1 Like

I had all of the same thoughts. I put in a new battery while holding the button. I've let it go for a few days to see if anything changed, but it acts as it should besides the quick inactive report. I got curious and fired-up the old Samsung SmartBeerMugCoaster, and found it does have the original firmware. It's updating as we speak. We'll see if the most recent firmware changes anything. I hope it doesn't!:grin:

Well, darn! Updated firmware gave it a 30 second inactive report. Mystery solved.

Curious did you use ST to update the firmware?

Yes. The process took about 35 minutes. Might have gone faster had I not clicked 'Check for firmware updates' so many times. I couldn't remember if there was a confirmation of upgrade or not...There is, BTW.

1 Like

Thanks. I had bought an Iris hub to update all my Iris device firmware but obviously it is dead now. I purchased 10 motions from eBay and should probably update the firmware on all of them via ST.

1 Like

ah bugger, i order 10 from ebay as well to Aus - but I dont have an ST hub at all to update them. When they get connected how can I check what version they are / if they have issues?

I don't think there is any way of seeing firmware versions with Hubitat. I'll look around on the web and see if I can find any information on the last version. That first one from Ebay I tried, worked perfectly, it was just the quick inactive event that was different from all of the others I use. I have 19 more. Don't think I'll bother checking all of them unless I find an issue.

@bjcowles, you made me look at some of mine (I also bought one of the 10-packs on eBay a while back). Turns out I have one that does the same!


As the device name suggests, I'm using it in the stairway and actually don't mind the short turnover time since I just use it to turn lights on as I pass through, and that's about perfect for that (plus I won't be setting it off so often that I'd expect significant battery drain). Good to know the firmware update seemed to have killed this "feature," which seems to lend support to Mike's hypothesis that they escaped the lab with test firmware (that had a low reset time) intact.

1 Like

Of the 19 others I purchased, three out of the five with older firmware had the quick timing "feature", and 13 were up to date, and one had a broken battery contact. I kept the 3 speedy ones as-is and updated the other two.

1 Like


Did you happen document firmware versions you saw while investigating this?

I picked up 20 motion sensors and 10 contact sensors from ebay.

I'm trying to figure out if a few are just bad or if they're on an old or test firmware. One of the motion sensors has the 8-10 second timeout. One of the contact sensors will pair, but will never show open. A few of the motion sensors will never update temperature (but do seem to report their current temperature when being paired). They also factory reset differently than the rest (displaying a long red light).

I paired one 'good' and one 'bad' motion sensor with Wink and see the following versions:

1.1b00 / 5.3b10
1.cb00 / 5.3b10

Oddly, it's the second one, which appears it might be newer, that's behaving badly. I don't know if Wink will attempt to upgrade them or not, but I plan to leave them connected overnight and see what happens.

I may pair them all with Wink just to see what version they each report ... especially if Wink does upgrade them to a version that works better.

On the motion sensors, SmartThings reported the old firmware as 0x11005310 and the final firmware as 0x1c005310. I was always under the assumption, but never bothered to confirm, that a red light meant low battery. (Green is good and multi-color is demo mode) Did yours ship with batteries? If so, it might be worth it to try a battery known to be good and see if you get better results.

Good luck

Issues where the sensors donโ€™t change states, Iโ€™ve tossed.

Iโ€™ve gone through new batteries and factory resetting them with no luck.

Thanks for replying.

Yes, they came with batteries, but I've already swapped batteries with another that doesn't flash red when resetting. The ones that have a red light during reset don't seem related to either battery or version as the problem remains with the same sensor regardless of battery used and I have others that don't go through a cycle of red on the same version (per Wink, at least).

Now that I've paired them all with Wink (temporarily), I see I have a mix of 1.1b00 / 5.3b10 and 1.cb00 / 5.3b10, but also one contact sensor that's on 1.1b01 / 5.3b10 that Wink seems to agree is Iris while pairing, but then switches over to Generic Zigbee and refuses to report temp. Temp was reported on that one in Hubitat.

Also of note they are all reporting temps fine in Wink (save for the one dead contact sensor that pairs and does nothing else), with the same variances, but over in Hubitat a few never update temp. However, elsewhere on these forums I read how Sylvania bulbs can mess with pairing. I don't have their bulbs but I do have their LED driver, which I'm going to assume may cause the same issue, so when I re-pair them with Hubitat, I'll see if they work better with those removed.

I'm about to do the same, I guess, with the one that doesn't work properly on both Wink and Hubitat.

The others may have had pairing issues on Hubitat due to my existing Zigbee devices, so when I move them back I'll pair them without those present and see if they work better.

Does wink support OTA updates for these devices? I read some ware the Smartthings does but first time for wink.

So far, the answer is no. I don't think they do, but I was just being hopeful.

I swear other Zigbee devices I've paired with Wink have received OTA updates (Sylvania Lightify, specifically).

In the end, learning the version on each didn't matter much. I have some on the same version that behave differently when being factory reset (as far as LED blink patterns go). Although I did find I have one contact sensor on a version that Wink pairs as Generic Zigbee, not Iris, I don't think it paired or behaved any differently than the rest over on Hubitat.

Oh, with the exception of that one, which doesn't report battery at all, the rest all report 100% in Wink but were (I think) 83% to 100% in Hubitat.

I'm almost done with sitting them on Wink for 48 hours ... back to Hubitat they go. Next task, getting logging and graphs configured.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.