Iris 3210-l integration issue

I have seen your "Lit" steps, looks very nice. Love seeing pics of others work.

I know! I do too! And thanks! I found a little gap in the steps, so the cord fit through the steps without having to "modify" anything. Made easy work of it. So it runs right down to my media closet in the basement. It was a cool score!

1 Like

Got to love it when it works out so well. The under cabinet lights I just put in I had planned to hook to my under sink outlet. I obviously didn't put any real thought in to this as that outlet is switched for the disposal. Fortunately the dishwasher is right next to the cabinet. 2 screws to pull out the dishwasher and a small whole that is completely hidden through the cabinet to run power to the LED's.

My Wife must have loved it as I now am being asked to install some lights above the cabinet.

This morning I had a switch I pulled out and my son (9 years old) asked me what it was for. I was looking at it for possibly nodding it in the future to use with a fancier push button. (Honestly this is an idea without a project.) Since my son took some interest I asked if he wanted a bedside light switch. He has never shown any interest in my world (beyond video games). Since he wanted the switch I asked him if he wanted to configure it. Surprisingly he was still interested and we worked through simple lighting. Was quite fun.

1 Like

=Priceless. Those are the moments that you hang on to. Keep him interested. If he continues, keep him involved. Reminds me of the movie "Son-in-law". Now I'm showing my age. That's awesome!

1 Like

Yeah, that is a nice story!
My 18 year old had a cumbersome question today, after automating lights in most of the rooms.
ยซWhy do I have to turn on the lights in the bathroom?ยป

He also saved up to buy some Hue stuff for his gaming environment himselves, but today he also wanted to do a swap that I get two of his Hue Light bars in exchange for a Ambilight solution for his gaming screen.
No luck in questions on how it all works though, but at his age, school, gaming and girlfriend keeps him bussy. :slight_smile: In Norway, we have free law school in universities, if you have top grades, and he is in, so he have prioritized impressively! (Proud dad)

1 Like

Bit late to the party, but I have 11 of these outlets,.

@april.brandt I'm using the Iris smart plug driver by shackrat and if i have it set to .5 on the voltage change it will detect when my google minis kick in. Not sure how nicely the driver will play with the zwave driver for them (i dont have any zwave devices yet), but worth giving a shot if your still looking for a way to detect when your alexa fires. :wink:

1 Like

Hmm this thread blew up, So What I gather I need to plug the device in close to the HE and after 3 sec. press the button 8x ? and it should show up to link as a Zigbee device?

For Zigbee pairing follow the steps in post 2 by @april, be sure also to put the hub in zigbee pairing mode.

The steps you listed above are for z-wave pairing.

Hey all,

I have a couple of these and 1 gives me an error on the Zigbee side, the others don't. Z-wave side is working fine

groovy.lang.MissingMethodException: No signature of method: user_driver_shackrat_Iris_Smart_Plug

Re-paired it several times, always finds it as a device previously paired

I'm using Shackrat's drives as well

Anyone else having this issue?


Double check the version of the outlet, and maybe check the firmware version.

It appears as though the device is sending some sort of reply that the driver isn't expecting and doesn't have an event handler set up for.

I know when I first started I ordered these off eBay and I was sent v3's instead which still set up amd worked but lack all power options and threw random code errors like that in my logs.

No luck I can only get it as a zwave repeater. Cant get it to work as a plug?

Based on what i understand about these plugs (someone who knows more please correct me) you HAVE to pair it in zigbee mode before ZWave, so odds are you are going to have to reset the plug and start over. (however you may be able to exclude the zwave portion, pair the zigbee and repair the zwave, but im not sure, again hopefully someone more knowledgeable can chime in)

Remove it from power and press the power button several times to fully discharge the device (you can also just wait 5-10 minutes to be extra safe)

Tell your hub to pair zigbee devices, the plug in the outlet WHILE holding down the button, release the button as soon as the light on the plug lights up. It should pair to your hub as a zigbee device after that, but you will then have to re-pair the Zwave portion.

If it doesnt catch on the zigbee unplug and plug in while holding the button again, making sure to release as soon as the blue led lights up.

It can take a few tries to get a plug to reset. Out of my 11, 1 of them took me over 8 attempts to get it to reset and pair to my zigbee, all the rest went first try. It really depends on the firmware on the outlet how difficult it will be and the exact timing.

Be persistent and you will get it!

I'm not even sure what to make of that error.. Take a picture of the label on the plug. I have seen some of the Iris v2 Beta smart plugs on eBay. (I have a couple myself).. They're crap. The firmware is really buggy. The newer gen 3 models work with the driver, but they do burp an error or two since they don't support all of the clusters.

You need to release the button IMMEDIATELY upon the light coming on. This took me a few tries to figure out.

That's correct (Zigbee before Z-Wave). You can re-do the Z-Wave pairing as many times as you want without affecting the Zigbee side; however the reset sequence for doing a Zigbee join does wipe out the Z-Wave settings as well.

For me the most reliable way to initiate Z-Wave pairing is to tap the button litterally as fast as my fingers can move, eight times. Any slower cadence of multiple presses won't really do it. And for some reason, Network Wide Inclusion doesn't work with these plugs (at least some of the versions that I have); if Z-Wave pairing is failing do it very close to the hub.

The light did not come on for me. This is how I paired mine on the first try.

start exclude zwave - turn the device on and off a few times slowly until it reads "unknown zwave device excluded'
start zwave inclusion. (I used a power strip with an accessible on/off switch. Made it less cumbersome.)

power on, wait three seconds, tap 8 times. It's fast , but not mashing fast. about 2 presses per second fast. My two paired right up the first time.

Thanks to @Brandon for hanging in there with me.


Hey Steve,

Here you go

The other one that was bought at the same time from Amazon, looks identical except for the serial number label and it works fine


Ok.. It's a 1st run 2nd gen plug.. It could have older firmware.

Try a factory test/reset and see if it behaves any better. You will want to unpair the Z-Wave side before you do this or you'll have an orphaned device. Don't worry about the Zigbee side, it'll re-connect on its own.

A factory test/reset is accomplished by plugging in the device while holding the button in. Unlike the configuration reset where you let go of the button as soon as the LED come on, this time you will hold it in until you hear the relay click. This takes about 10 seconds. Once that happens release the button and pull the plug from power. Wait a few seconds, then do the config reset procedure (plug in while holding button, release as soon as the LED comes on).

The try re-pairing to Hubitat again.

Any tricks to get it to un-pair? No luck so far


Edit: OK finally got it to un-pair
Settings > Z-Wave Details > Z-Wave Exclude never worked no matter the pattern, process...
Even deleted the z-wave device, no luck

What worked for me was...
Devices > Discover Devices > Z-Wave > Start Z-Wave Exclusion
Worked first time, go figure

Re-pairing was simple, same with zigbee

I'll keep an eye on the logs


During a Z-Wave Repair