iPhone Mobile App: "Error 404"

IOS 14.4

When I open the Hubitat app on my iPhone, I can go to the Dashboard and control devices, but when I attempt to open the "Connect to hub" link, I get a"404 Error" message. This happens whether or not I am connected to the same local network as the hub.

I can access the hub on my local network by going through a browser on my phone to the hub's IP address. From the browser, I can access all features. I can also access the hub and all functions from my computer browser.

I have tried shutting down the hub and restarting it. That changes nothing.

I have removed the app from the phone's memory and restarted it --no effect.

I am able to access the hub controls through the app via the new "Remote Access" subscription, but not on the app itself while even while connected to the same network as the hub.

This problem started about 2 weeks ago. I've been going around it, but it's annoying and certainly an indication something isn't right. None of the material I've read through or searches I've done have shed any useful light as to the cause.

This problem was solved by deleting the app and re-installing it.