IP address reverted to old address on software update

Yesterday I moved my Hubitat C-7 from one subnet to another. With some difficulty, I managed to move it to the new subnet (had to remember to do a shutdown from the management app, then move the cable and then power cycle the unit).

Today I updated my unit to and it didn't come back from reboot. On a hunch, I connected it to the old subnet and sure enough, it was at the old address. Using DHCP, not static config

So now I'm trying to get the hub on the new subnet again and nothing seems to work. I have tried:

  • software shutdown, connect to new network, and power cycle.
  • pressing the reset button on the bottom (both short press and >7 sec press that seems to reboot) while connected to the new network
  • Configuring a static IP address, router, DNS on the new network while connected to the old one. The configuration gives me an error that I won't be able to talk to the hub at that address (I know that) and refuses the configuration change.

Honestly, it should be as simple as unplugging from the old network and plugging into the new one, which should cause the hub to make a DHCP request on the new network when it sees the Ethernet is reconnected.

This hub is at our vacation home. I'm glad I'm here at the vacation home doing the update rather than doing it remotely or I would have lost control of the hub.

One of my C-7's were stubborn when I went from subnet to subnet. I had set the static address and moved the cable like you did and it didn't work. What I ended up doing was putting it on the old subnet. Toggling back to dynamic address to static a couple of times to make sure the address stuck on the old subnet then configured for new subnet with a static address and shutdown. Unplugged the cable and moved it to the new subnet and rebooted. I also shut off auto-reconnect since it's not needed with most broadband connections.

This happened a long time ago when reworking a network so your mileage may vary.

@user4390 Start fresh. Press the network reset switch on the bottom of the hub for 7 seconds using a toothpick or paperclip. It will be the only round hole out of all the square ones. (This will clear the network settings and revert to dhcp). Go into the hub and set a static ip, make sure you actually set dns (it may be be prepopulated but you need to manually do it) and set your gateway. When you click save, you immediately will NOT have access to the hub. Move cable to where you want it. Log in and make sure you have access. You should be ok. You can reboot the modem if you prefer after. I would recommend though that you enable DHCP reservations instead.

In general, it's best networking practice to reserve the IP address at your router vs for an individual device. To do this, you link the MAC address of the unit (in this case your hub) to the static IP address you want it to have...then set the hub to get it's address from DHCP server (i.e. your router).

This avoids duplicate IP addresses.

Again - best networking practice.

Just to be clear, I haven't been using static addresses. I also can't configure it for the new subnet, unless there's some trick that allows me to override the error about not being able to talk to the router at the new address. Aside from that, I think I have tried the rest of your suggestions except auto-reconnect. In any case, thanks for the ideas.

I have tried the reset button several times and it doesn't seem to do anything except reboot the hub. I haven't found any indication that it caused it to DHCP successfully on the new network. And since it wasn't on the new network, it wasn't possible to log in and set static IP, gateway, and DNS.

It doesn't appear that my router (Ubiquiti) supports DHCP reservations, but I can configure an address outside the DHCP range and that should do the trick, if only I can do that.

If a 169.254.x.x address is being assigned to it - that is an indication that no DHCP server is answering the dhcp discover broadcasts on that subnet.

Yes, that's what usually happens but how would I see that address if I need to connect to the hub to see it?

That being said, a 169.254 address did show up on my list of subscribed hubs at one point, but I'm not sure how it ever communicated that to the subscription service.

Well if your router is performing vlan functions, you should be able to have the DHCP server set to apply address' to that Vlan's subnet. If you are simply on a flat network, the DHCP server will only issue address' on it's primary subnet not others you may have created. If you are running proper VLAN's you also need to tell your hub to add your primary vlan to it's permitted scope using an end point.... IE: ```
http:///hub/allowSubnets?, etc

I'm not running VLANs, at least not here. I'm switching from one access router to another, temporarily with the new router connected to the old one (double NAT). Once I get this all working, I can switch the old router/cable modem to bridging mode.

Liklely your DHCP servers on each router are dukeing it out. You are better off pre programming the new router with DHCP reservations (also set up on the same subnet) then simply turning the old one off and disconnecting it and putting the now pre programmed one in.

1 Like

Even though I'm not using VLANs, I thought I'd try using allowSubnets to see if it would help me work around my problem configuring a static IP in the other network. But it just returned a 404, and didn't seem to do anything:

Because the endpoint (URL) you used is incorrect. It should be:,


Like I said, stop trying to use two routers. Just pre program the new one. Things will go much smoother..

1 Like

I think I've been looking at the wrong layer. Neither my router nor the Hubitat have indicator lights for Ethernet status, and when my Hubitat is connected to the new router it doesn't seem to see it at all. Both ends are set to auto-negotiate (have also tried FE HDX and FDX) and the same cable works when connecting to the old router. Have also tried multiple ports on the new router. Not sure what is preventing them from connecting. It was working on the new router until I upgraded the Hubitat firmware.

Agree w/this...every time I've changed routers I had the smoothest path just cutting over to the new one. To each his own, but the additional complexity of mutiple routers won't help.

I can't imagine there is a Ubiquiti router that doesn't do DHCP reservations. Which model router do you have?

1 Like

Confirmed that this is a physical Ethernet connectivity issue. I put an Ethernet switch between the router and the Hubitat and it works fine. Still puzzled about why a direct connection isn't working.

1 Like

The router is a Ubiquiti "Dream Router" (UDR). Perhaps there is a way of doing reservations, but it's called something else. The main control I see is for the range of addresses that DHCP will assign, so I thought it made sense to just assign a static IP outside that range (+gateway, DNS).

In the GUI, select clients, select the actual client, click configuration tab, then used fixed IP......type in the IP you want to reserve.

1 Like

Thanks. Until I get the Ethernet connection issue sorted out, I'm leaving the Hubitat on the old router, but will try this once I have it on the new router again.

1 Like