IP address of hub changed, but my.hubitat.com still has old IP address

Hi All,

Just received my Hubitat hub and was setting it all up.

I changed the IP address from dynamic to static and it's working perfectly fine accessing the web page on the hub directly.

However trying to use the mobile app (on iOS) it can't find my hub. It's looking for it at the old IP address. Also the my.hubitat.com site still shows my hub on the old IP address.

I tried de-registering the hub, and finding it again. I punched in the MAC address, and it found it, but comes up with the old IP address.

Is there a way to force a refresh of the ip address?

--
S.Lam

The Static mode is interfering with the DNS lookup, the quickest way to get things communicating again is to do a network refresh by pressing the reset button on the bottom of the hub.

https://docs2.hubitat.com/user-interface/settings/networking

1 Like

If possible it would be better if you can set a static DHCP reservation for the hub on your router.

If that is not possible, you may need to reboot the router after setting the static IP on the hub. Rebooting the router should clear out the DHCP reservation it had for the hub and it will lock onto the static IP once the hub starts chattering.

1 Like

A reboot doesn't seem to work. I simplified the static IP configuration by just entering in 1.1.1.1 as the DNS server. Just in case it didn't like my local DNS server (PiHole). By the way, the hub really makes it hard to change static IP settings.

jtp10181, I don't see how that would help. I can reach the hub on my LAN via the IP address I assigned. I don't see how an external server could query my LAN's and find if in an IP address on my LAN was assigned by DHCP or was static.

Anyways, I logged into my DHCP server (it's not on my router), and released the old IP address that was associated with the MAC address of my hub.

Still doesn't work. Even if I de-register my hub, and look for it again. It finds it... but lists the old IP address still. Oh, when I say it "finds it", I always had to punch in the MAC address to find it.

Was just a hunch that might work without knowing exactly how discovers the IP address. How long have you waited since changing to the static IP? I would maybe just let it sit overnight and see if it finally refreshes it.

I assume your hub is being allowed to connect to the internet? It might be telling its local IP to your cloud account so that the web interface easily knows how to find it.

If you use the advanced discover of mDNS or LAN scan do those find it?

EDIT: Also on the hub go to Settings > Hub Details, see what IP is being reported there for the hub. I vaguely remember a case a while back where someone was having a similar problem. Might have to dig up that old thread to find the solution.

Hi jtp10181,

Sorry, yeah, your hunch was still worth a try.

In Settings/Hub_Details it's showing my assigned static IP address.

I'll let it brew overnight and see if it updates tomorrow.

Thanks for the sugestions,
S.Lam

LOL... I just decided to just check the hubitat website before I head off to bed... and it updated the IP address!

Welp, I guess it eventually called home and updated it's ip address. sigh Patience is a virtue.

Again, thanks for the help everyone.

Download the Hubitat app