iOS geofencing

I've read every post I could find re iOS geofencing. They're all being asked by folks who actually have geofencing doing something.

In my case, geofencing is enabled, a range around my location is set. When I go outside of it, nada. When I return, nada.

Location is allowed in iOS. Does this particular aspect of the mobile app work without Remote Admin access?

I'm having an issue with the iOS app. It doesn't work for me when I Allow Location Access - While Using the App. It only works when I change it to Always. I don't have Remote Admin access.

Do you have any rules that fire when you are away or home? Are you using Modes Manager?

I have 4 family members using geofence in Hubitat app. 2 are Android which both work flawlessly and the other 2 are iOS and they're both flakey. I have location set to always and background refresh allowed but every 3 or 4 days someone has to open the app and "send a geo event" from settings to get it going again.

No. Geofencing for presence automations was one of the original reasons they released a mobile app. So it’s been a part of the app since the beginning and is unrelated to the new remote admin subscription service.

Does anything happen if you go to the settings menu and tap “send geo event?”

1 Like

If the app can’t track your location in the background, it won’t really be able to function adequately for the purpose of sending geofence events.

1 Like

Yes, actually. If I manually fire, the magic happens. But, admittedly, I was at home having returned from a short jaunt so I just wrote it off to being on my local network (that it worked.)

Using Modes Mgr, yes. I'm slowly building the system out so rules are minimal atm, mostly test rules.

OK so if you can send a manual geofence event that works, it sounds like the app on your phone is properly linked to your hub through the Hubitat cloud, as it should be (I don’t think geofence events are sent locally, although I’m not 100% sure).

There are a few options in the “advanced settings” sub-menu. What’s selected there?

It worked fine for my application of turning on my exterior lights when I got home really late. All I had to do was open the app when out of the area then open it again when I got home. Not a big deal for me because I can just open the app and turn my lights on. It just eliminated a couple of taps on the screen. It was working fine but the latest app update appears to have broken While Using the App option. Just trying to point out to OP to use Always option.

I could see that. But if you want, you can always setup a more automated way of turning your lights on late at night when you arrive home and cross the geofence. That's what Hubitat's really good at :slightly_smiling_face:.

In my experience on my iPhone Pro 12, and the iPhone XS I used before that, setting the app's location services to always-allow doesn't cause any more of a battery drain than in-app only. Unless you enable "high accuracy" location. That seems to be a battery killer.

There are minimal privacy implications of always allowing location services for the app, if that's a concern for you. It only communicates with Hubitat's cloud when a geofence crossing event occurs, and that's all it discloses. It was designed so that no other tracking could occur, even when on in the background. A nice touch, if you ask me.

Update: it recognizes when I leave just fine. Coming home, nope. I have to press the "send event" link in the app and then it responds perfectly.

Everything is set to off in the Advanced Options menu.

I'm afraid to write this... it's been working for about four days straight. Shhhh....

1 Like

Download the Hubitat app