[iOS Beta 1.3.1 (158)] App frequently using my location until I force close it

I am on iOS 17 if it matters.
Using the latest Beta app from TestFlight.

This is from an apple help page:

I am frequently seeing this blue status on my clock and when I tap it, it takes me to the HE app. Usually when I see this it would be if I left a GPS navigation app running in the background. The only way I can get it to stop is to force close the HE app. I was traveling earlier this week and after force closing the app it would come back again after I changed locations which I assume is due to geofencing but it seems like it is getting stuck and constantly using the location once it checks it.

  1. I am concerned this will be draining the battery
  2. It is extremely annoying.

Are you using geofencing? If so, the app needs to know where you are.

Yes, and it has always been enabled but never has it been stuck using my location for long periods of time as it is now, causing the blue indicator around the clock. This is only happening with the new beta version.

1 Like

Do you have “send presence only while in motion“ turned on in the advanced options?
That may disable location services for the app while it is sitting still. It appears to do so on the release I’m using. 1.3.1 build 158

Yes I have had that enabled for some time.
I also have Validate on network change enabled, which I did try turning that off earlier this week and still ran into this issue.

Same for you?

Yes mine is the same, also allowing Camera access (for Smart Start), but that is not relevant here.

I "normally" do not have Hubitat app open so the location "blue arrow" is not shown when app is in background.

I see the same issue. Only happened with the last two builds where my dynamic island shows Hubitat constantly using location.

This Status Bar indicator for presence was added to improve geofence detection. Removing it may decrease the success of detecting a Geofence IN/OUT.

That said in order to give the option to use (or not) this we have added a toggle option on Advance options to remove that (currently on beta).

Also this indicator doesn't increase in any way the battery consumption.


Ok thanks, I have noticed that the presence detections is now on par with my homekit virtual switch I also use, so it is greatly improved. I will try turning that indicator setting off on the new beta version and see if it still works as good.


Is this the same reason I get a warning every time I open the app in iPad OS17 that the location is disabled and I won't be able to use geofencing (even though I have geo-fencing turned off)? I don't use the app for geofencing on the iPad or phone, but I always (and only) get this alert on the iPad. I never get it on the phone. The only thing i even use the app for is SmartStart Zwave inclusion.

If you are using the Beta app I would say that is worthy of a separate post. Sounds like it is still trying to use the GPS even though you have geofencing disabled.

1 Like

I'm pretty sure I'm not. I was on Android, but I never signed up for the beta group for iOS. The only beta I ever had on iOS was hubivue. When that imploded, I removed testflight from my phone, and never had it on my iPad. Really the only thing i use the Hubitat app for is Smart Start. Notification I use pushover, and geo-fencing with the Hubitat app has always been spotty at best regardless of the platform, I use Geofency for that.

It appears that turning off the Indicator setting has rendered the presence detection totally useless. It has not changed at all since 10/25. This is worse behavior than prior main versions.

It was still not working, I had to "Select Hub" and link to the hub device again, and then force push a geo event. I will try testing with the indicator setting turned off again next time I go out.