iOS App hangs on Login


#1

iOS App still hanging on login. It just gets stuck with this spinner until I force-quit it. Once I re-open the App, im logged in. Seems I didn't actually need to select a device, not sure why its asking.

iPhone X running 12.4. App version 1.0.4 build 48.


#2

It has always been like this for me. Force quit the app and re open it and it will be fine.

You may have to occasionally re identify your phone as the right phone and delete extra presence devices that were automatically created.


#3

Same here. Every now and then I’m logged out. I only realize this when geofencing stops working.

When I sign in it hangs as the same spot.

Force quit and relaunch and it’s back again.


#4

Same here. I've had this since the first release on my iPhone 7.


#5

I'm on the beta app 1.0.5 (52) to see if it resolved any of these issues but not yet. I provided feedback about the loading mobile devices having to be force quit.


#6

Have not experienced this at all. Am I not launching enough? I’m running beta, but have not had this on any beta version so far. Also running on iOS 13.1 beta at the same time.


#7

Do you have multiple devices under your account? perhaps it doesn't occur if there is only a single device?

Paging @Patrick, I was waiting it out as I figured this would get fixed eventually, but its been a while...


#8

By devices, you mean hubs? I have two hubs. Both under the same account.


#9

no I mean the mobile device you run the app on, ie I have one for my iPhone and one for the wife's.


#10

Same as you.


#11

I also have to Mobile App Devices on the selected hub (plus two more hubs that I've never used in the app). I thought I tried force-quitting the app, but I know I tried the more drastic step of deleting and re-downloading the app, which allowed me to log in, select my hub, and select my device without problem. :slight_smile: (Had this happen twice about two days in a row but has been good since then, so hopefully I won't have to try this again...)