[iOS 2.0] Switch to another hub does not ask for device

From welcome screen, tapped hub name then switch to another hub. It asks me to select the hub but then does not ask which device to associate with. On my main hub there are two mobile device so it for sure should be asking which one. Not sure how it is deciding, but it is attaching to a device.

3 Likes

This is still an issue in build 239.

@moncho1138 I deleted the app and reinstalled it due to crashing, much to my surprise it still only asked for a hub and then automatically selected a device to attach to. It was the correct one but not sure how it is deciding? This was on build 239.

A new feature on this app is that the deviceId will persist even after uninstall so it picks the right one everytime without creating duplicates.

1 Like

I think that is good for people who may switch the app between hubs, less chance for mistakes.

But, what if the wrong one gets selected and I want to change it to a different one?

For example on my C7 hub I only have one mobile device. The new app on my phone has attached itself to the device that was created for my Android tablet (to use smart start). Not sure if I picked that at some point or what, but now I have no way to change it unless I delete that device from HE. Which if I have a bunch of notifications tied to it, that would be very annoying.

What actually happens with presence if you have the app on two difference devices pointed to the same virtual device on HE?

In the case of presence, the last phone to select a mobile device is the one that will send a presence change to the hub.

Although this seems like a great idea, this does not work right now (at least for me).

I think that this is the reason...

  • installed beta app
  • registered on hub and device with beta app
  • opened the v1 app after having multiple crashes from beta app
  • logged out of v1 app after a new version was out
  • now using beta app but not receiving any notifications and geofence is not working, so I'm connected to the hub but not the device if that makes sense?

Did not try logging back in the v1 app yet, want to see what @moncho1138 might suggest first.

I also went without notifications for a while, until I went into the mobile device page and pushed one directly from there, while the beta app was open. Notifications magically reappeared - or was it a coincidence?

Tried that but did not work for me with the latest version.

Just tried it again just in case, but no go :frowning:

So I tried logging out of Beta app, logging in v1 app, sent message from hub and received it as expected.

Logged out of v1 app, logged in Beta app, sent message from hub but did not receive anything.

I'm under the impression that it's not connecting to the device for some reason, did not see anything in the device logs nor in the events about app connecting to the device (might be a nice idea to add this to the driver ?), only logs or events are "message sent message to iPhone Nelson".

If you want me to test anything else, let me know.

@moncho1138 This is still an issue in 252

Is there any plans to address this or will you just be stuck attached to the same device on the hub if you select the wrong one on accident or need to change it for some reason?

There could be a separate option to switch the device. This way if people are switching hubs it will be smooth without asking for the device (using the last one attached however it does that currently), but if you really need to change to a different device there is a separate way to do that.

Same issue here also, maybe at least have a link to switch device somewhere?