Interrupted Hub wifi connection

I'm using my Hubitat C-7 with a recommended TP-Link nano WiFi adapter:

What I see is that any interruption to WiFi connectivity causes the hub to permanently lose network. It doesn't seem to attempt to re-establish WiFi periodically. I waited 15 minutes after the network came back: still no connectivity and the radio LED doesn't flash green anymore. Is there any chance the WiFi driver can be made more reliable?

I am experiencing the same thing.

Did you ever find a solution. I am thinking about using a rule to verify the hub can ping the gateway and if it canโ€™t then reboot the hub.

It sucks but I donโ€™t see any other option.

Might be something @gopher.ny can look into.

Yeah, I can most likely build in the same sort of check that wouldn't require a reboot into hub itself.
I run the "big antenna", longer range adapter on my hub, but can switch to the "nano" adapter.

1 Like

I have the same issue, if I disconnect the nano adapter then reconnect it, after the hub has lost the connection, I can see the green light on the adapter starting to flash again. The connection seems to be established but the hub does not ask for an IP so canโ€™t go back on line.

Upcoming 2.2.9 has additional reconnect logic to address this issue.

Hi folks,

Sorry for digging this one up again. My hub still seems to have this issue with not reconnecting to wifi after any kind of loss of network. Did more recent updates 2.2.9 and beyond solve it for most people? I have the very latest updates.

Many thanks,


I guess I must be alone in still having this issue? That is strange but as every setup will be different, it could be the case.



@gopher.ny were there additional changes to address @Monty73 โ€™s issue?

1 Like

2.3.0 has automatic reconnect logic whenever WiFi is used. I run my house hub on WiFi, and it made a difference. Same logic can be manually activated with wired connection, but it is not enabled by default. So yeah, please update to 2.3.0 and see if that improves things.


I'm so excited for this fix, thank you! I updated to the new firmware as soon as I read your message @gopher.ny. I reset my network and the Hubitat remained available, so so far so good! Is there any indication in logs that a reconnect was required? If not I'll just assume it worked silently and flawlessly. Thanks again!

There's nothing in user accessible logs. If you PM me your hub id, I can confirm in the engineering logs on the back end.

@gopher.ny confirmed that my hub did reconnect to WiFi (twice). From my perspective (as the OP) this issue looks fixed!