Internal error migrating from C-5 to C-8

I am trying to migrate from C-5 to C-8 and following the instructions at How to Migrate to a New Hub | Hubitat Documentation and Registration and Setup | Hubitat Documentation. When I attempt to restore form the C-5 cloud migration, I get an error. How do I proceed? For now, I have booted back up my C-5 and everything is working fine.

I was able to connect to the new hub, and tried it again using backup/restore, but that also failed.

After the above failure, I saw no devices on the new hub. So I tried updating the hubitat version on the new hub (to, and then suddenly all of my devices showed up. But none of them work. I tried turning on and off zigbee bulbs, z-wave switches...nothing happens. I tried the restore from migration backup again, and same "internal error". Plugged my old C-5 hub back in and thankfully everything still works. No clue what to do at this point.

We've had a few incidentes reported recently with migration failing from C5 to C8 and we are currently investigating. Please send me a private message along with your hub id.