Internal error during C-5 to C-8 migration

I am attempting to replace my C-5 with a C-8. When I select Migrate and select the backup file I created from my C-5, it works for several minutes and then says "Internal Error". I have repeated the process three times with the same result. After the error, no devices or apps are on the C-8. Any advice on what I should try that would vary the process enough that expecting a different result wouldn't fit the definition of insanity?

Are both hubs updated and running the same Hubitat firmware version?


Yes. I have done check for updates on both.

1 Like

I have tried a few more times with the same results. Here are some more details of what happens:

After selecting the migration backup and clicking "Migrate", the new C-8 initially appears to be doing the migration. After a few minutes, an error message appears sayng "an internal error occurred". The devices appear in the devices tab. The apps all seem to appear in the apps tab. In the Zigbee Radio Details, my 7 zigbee devices show up. In the Z-Wave Radio Details, no devices show up, even though I have dozens of Z-wave devices. I tried doing a Z-Wave repair, but it seems to hang and not change anything. When I go to the page for an individual Zigbee or Z-wave device, the devices do not respond to any of the buttons that should cause something to happen. In the Apps status log, it shows that there were a little more than 3 minutes of App runtime. That number does not increase any further, indicating that the apps don't seem to be re-activated.

Any ideas of other things to try before I start a warranty claim?

Do a softreset on the c8 as well as reset both radios.

Turn off c8 power (pull the plug)

On the c5 to a soft reset and restore. After, shut down and unplug power the hub and wait 2 mins. Power back up.

Do migration backup. Shut down c5 and unplug power.

Power up c8 (make sure you are using oem power supply) and see if migration now works.

1 Like

What country are you in? Are you using the C5’s built-in Z-Wave radio? Or are you using an external USB Z-Wave radio?

I am in the US and am using the built-in Z-wave radio.


Did the above work for you?

No. That didn't work. Now, I get an internal error when I attempt to restoring the C-5 from the backup. Now, neither of my hubs is working.

It seems to be going better when I restore my C-5 from a local backup instead of a Cloud backup. Does this screen mean that the restore has completed, or that it hasn't?

It probably has completed, should be able to just close the browser window and open a new one to log in. Sounds like maybe there was an issue with the database which translated to the cloud backup. Now that you cleaned that up with the local restore, try a cloud backup again. Hopefully the C8 will take it now.

My old C-5 is now blank. No devices. I no longer have a working hub. That soft reset thing on the C-5 was a BAD idea. (BTW, it controlled my HVAC system. Hopefully, I can get something working before the house gets cold.)

After unplugging the C-5 and then plugging it back in, it seems to be working again, with all of the devices that I have tested so far. My panic level has decreased somewhat.


Since I leave town for a week tomorrow, I think I should wait until I get back to work on this any more.

1 Like