Intermatic z wave device setup help


I have 2 Intermatic HA20 switches which I am unable to set up. The switches have not been found when I do device discovery. Unfortunately, I have not found any info on Hubitat on how I should proceed. Thank you in advance for any advice.


The manual is below

I have an HA18C, which is the on/off switch that is similar to your HA20C dimmer.

I had a hard time pairing the switch in my z wave network until I took the instructions literally and got the z wave controller very close to the switch -within an inch or two. The switch works fine now, though it is about 10 feet from another device that acts as a repeater.

I believe these old Intermatic devices have a previous generation of z wave chips. They do not have the range or sensitivity of the newer devices, and they used a "low power" strategy as part of the inclusion process. Also, I don't think they support network wide inclusion like newer devices do. I literally held the USB stick on the controller a few inches from the switch and was able to get it to pair. Once paired it reverts to "full power" and works normally.

I keep the old Intermatic switch in my network because it has a high tungsten load rating compared to most of the z wave plus switches.

Hi Muir,

Thanks for your replay. After finding a long cat5 cord I did what you suggested. Unfortunately, my switch still did not pair. It sounds like I may need to upgrade unless another potential solution comes along. Thank you for taking the time to reply (your info was very helpful).


You didn't mention it so I'll ask.. have you excluded the switches before trying to add them to Hubitat? This will be necessary for the inclusion to work if they were joined to any previous Z-Wave network. Start the Z-Wave exclude from the Hubitat (Settings >Z-Wave Details > Z-Wave Exclude ) and flip the toggle switch as the documentation describes (probably would be a good idea to do this with the Hubitat very close to the switch).

Hi Tony,

I did exclude the switches before trying to add. I also flipped the toggle switch and had the hubitat an inch or two away from the switch while in discovery mode with no luck. Spent a couple hours trying to figure it out with no luck (but at least I tried what you suggested). Thanks again for your assistance!

Have you tried clicking the little slider on and of periodically while trying to pair?