Inovelli z-wave association tool

I have been trying to install the Inovelli Z-wave association tool from Github but keep getting an error message. I am trying to get the tool here:

I get the following error message:

No signature of method: Script1.definition() is applicable for argument types: (java.util.LinkedHashMap) values: [[name:Z-Wave Association Tool, namespace:erocm123, author:Eric Maycock, ...]]

Anyone have any thoughts or suggestions? I appreciate any help. Thank you.

No issues here. Did you copy/paste or import the raw url ? And make sure you are creating a new APP not driver.

Just tried it the first time myself, using link that @anon61068208 shared.
Saved as New App, open it up and click on "Create New Association" and Error popped up?

Doh! I was trying to install as device code instead of app code. Thanks for setting me straight.


once the code is added you need to go to apps page and add the app by clicking the "add user app" button at the top right of the page. Then you can access the app from the app tab and it should work.

Looks like you need also but its not working so I'll look into fixing this.

Ok I fixed it.. let me fork his repo and submit a pull for it. I'll post the links to both apps here when I'm done.

Ok fixed apps are at Hubitat/Apps/z-waveat at master ยท sgrayban/Hubitat ยท GitHub

Install both as a APP not a driver.


Pull request 15 created


The original error only happens when you use the import feature. If you copy/pasted the child app error does not show up. I am assuming this is because of a file encoding oppsie on Eric's end.


@anon61068208 Thank you, Sir! Working fine for me now!

1 Like

Awesome sauce !!

BTW I am @anon89238910 here but it just happens I am logged in with my personal account tonight as I normally work between 12pm to 5pm PST M-F