Inovelli red series dimmer takes forever to turn lights on or off

As the title says. I have an Inovelli red series dimmer paired with Hubitat using the most recent driver. When it single press the switch ( up or down ) I expect the light to go on or off. What happens instead is it take 15 seconds ( I timed it ) to do either function. I have tried the following.

Using the switch itself to set dimmer speed - Failed

Use the Hubitat device page to set the dimmer speed - no clear control for dim speed - Failed

Exclude switch, factory reset ( on off function works with a 2 second dim rate, completely acceptable. Add device to Hubitat - Failed, dim speed is once again 15 seconds

Read through the forum, watched all the videos on setup, read the docs on Inovelli site.

Result, incredibly frustrated, and extremely confused. Hubitat seems really solid, but can’t understand for the life of me why non-descript parameters do not have or require a description to explain what the actually control.

Please help, I would be eternally grateful.

Edit: additional info. I have the lzw31-sn, but am using the Hubitat driver for the lzw30-sn as that is the only one available for the Hubitat via the Inovelli GitHub. They have one for smarthings, just not Hubitat specifically. I am not sure if they are interoperable so went with the device specific drive that was the nearest match

I use Inovelli’s community driver and the light dims at the rate that I setup in the device page. Have you tried that one? (I assume you are using the Hubitat driver?). It can be installed via Hubitat Package Manager.

I am using the driver found on the Inovelli GitHub here

What setting are you using to adjust the dim speed?

I have noticed that when changing some settings, like LED color, it has no effect. That is a separate issue, but figured I would mention it.

Also, just in case it’s asked the switch is well within range of the hub and has a strong signal

That should be the same one I have. Under Setup, I have my dimming speed set to 1 and to 2 from switch:

Interesting. I do not have these options at all, I will attempt to screencapture all the options I see and post it here in a few, tricky to do on a tablet.

It is not very clear where the 15 seconds happen. Do you mind elaborating on the difference between the 2 seconds and 15 seconds in your statement above? A 15 seconds latency cannot be adjusted from parameters. That is unusually long time. Are you manually dimming from the switch itself or Device Details page by setting a dim level?

Not a problem. The times mentioned are the time it takes for the light to got from off to on via dimming.

2 seconds - applied to the Inovelli switch after factory reset and exclusion. So just the switch itself. This is totally expected and desired.

15 seconds - time it takes light to turn on or off. This is after adding the device to the Hubitat and with no changes to any parameters.

Method: using a single short press on the up or down toggle. Not looking to do anything with press and hold or other functionality at this point, just want to get the basic on and off functionality working in a reasonable manner.

Wow, that is very odd. I would reach out to Inovelli support for that. I have a ton of these dimmers and never experienced this problem and we didn't have any tickets on our side reporting similar issues.

I was thinking the same. The only problem is I have two switches and both are doing the same thing, so I am more inclined to think user error.

The odd part is that the photo of the preferences the other post sent are not the same preferences I am seeing. I have no options that say they control dim speed.

Here are some of the options is see

There's your problem. You are using the driver for the Switch, not the Dimmer. While they are similar, they are not the same and don't have all the same parameters.

Inovelli has Hubitat drivers for all their devices here...

And specifically, the one for the Red Dimmer (lzw31-sn) is here