Inovelli Red Series 2-1 Dimmer/On-Off Switch Notifications

I recently installed a new Inovelli Red Series 2-1 Dimmer/On-Off switch. I set the switch to Dimmer mode as Inovelli instructions indicated. I then followed the Inovelli instructions to setup notifications to be sent from Hubitat to my Red Series 2-1 switch, using the Inovelli Switch Toolbox page to get the correct parameter code to paste in the Hubitat Rule Action.

I set up the Rule in Hubitat, setting Trigger and Actions and pasted in the parameter code as per Inovelli instructions. When the trigger goes off the notification set in Actions goes out (I see so in the Hubitat log) but nothing happens at the Inovelli switch LED. I've tested several times and recreated the Hubitat Rule just to make sure. Still no luck.

However, when I set the same parameters (that I used in the Inovelli Switch Toolbox to get the right parameter code) in the ledEffectAll and send the instruction out from the Edit Device page for the Red Series Switch in Hubitat the switch LED updates as expected (i.e., the notification signal works).

How are you doing this in Rule Machine? I don't see a "dedicated" way to do it in Inovelli's custom driver, so I assume maybe the setParameter() command as a custom action? If so, maybe show all the parameters (and their types) that you're providing for this action, and someone can see if something looks off.

Also, I'm assuming you're using their "new" toolbox that's been updated for the new Zigbee and Z-Wave models, as the values are calcualted differently from the original community tool.

You choose run custom action and then set 4 number parameters like the following:

Top one sets it to solid red and second stops it and goes back to default color.

I followed the Inovelli instructions here:

The instructions I posted in my reply above show a single number entered for the parameter, as opposed to comma delimited values you mention. Have you set the parameter values this way and have it work?

I think Jonathan's Mini Dashboard app is available for the new Reds, but I'm not certain... I don't have any of the new Reds, but his Mini Dashboard app is a godsend for the Blues - it works awesome.

It's available in HPM.

Correct, 4 separate parameters are entered but show up comma separated in the UI once done.

Interesting; those say to use the command ledEffectAll() with a single string parameter (generated by that tool), but I don't see anywhere in their code that actually accepts such values. It should work if you use four number parameters (as described in the command at the top of the page), or you could use setParameter() for parameter 99, size 4, and the calculated value you already have. I just don't see a way for this to work with their driver as-written...

That is not what I experienced. I entered the single digit string value as the run custom action parameter value under the Rule and after saving the Rule the single digit is what remained when I viewed the Rule. I did try changing the parameter type to number and enter both the single value and comma-delimited values for both string and number parameter types for ledEffectAll. Nothing seems to work.

I believe this is because the command is mis-documented (or perhaps not implemented as they originally imagined), and either of the alternatives I mentioned above should work in the meantime.

I think so because I turned on all the logging for the Inovelli device and could see that the ledEffectAll custom command parameter is expecting a single value. The trace log threw an error indicating it was expecting a single value. I put a ticket in with Inovelli so hopefully they will update the Hubitat driver and/or switch firmware to resolve the issue.

This is a documentation or driver issue, not a device firmware problem, but that's good idea, and I'm sure they'll fix it!

With some help from people on the Inovelli forums, I was able to get things working. The Inovelli instructions for setting up the notifications in the Hubitat Rule Machine aren't correct. You need to add all 4 parameters for the ledEffectAll action to work as mentioned by ritchierich above, but I didn't know that you could stack the parameters for the action in the Rule Machine. Took me a minute to figure it out but it's working. Here's a screenshot of a working config for others that might not be aware.