Inovelli LZW42's and Dashboard Bug?

Setup 3 LZW42's. I have them on the dashboard as Color Blub. I can bring them up and set color and level but when I click the X to return to the dashboard the bulbs go back to white. When I click to go back into them they show as 84,84,84 where I had them as 0,0,255. What am I missing here? I wouldn't think it would be this hard to get these to hold a setting. I am on a C7 at 2.2.6.140 and the LZW 42's are on 2.3.1 firmware. I have tried both the Inovelli drivers and the Hubitat drivers but I get the same results. All bulbs have had 'Configure", "Save Preferences" and "Save Device" clicked.

Anyone?

Are you seeing any errors in the logs when you set them?

Do the actual bulbs go back to white or just the bulb icon on the Dashboard? What does "Current States" on the device page look like while all of this is happening? My guess is that there is a problem there, since Dashboard would just be reading those values to determine how to display the tile. Also, is this problem LZW42-specific, or does it happen with any bulb (e.g., a virtual bulb you might create to test this)?

...Virtual generates errors and then resets when changed from the device page

They go back to white.

Here is the dashboard when I have set blue and the light is indeed blue:

Here is the status while the dashboard is blue so it looks like it's thinking white:

Then when I click the X to get out of the color selector the light goes white but the status page does not change.

The log shows this:

This is after setting blue and curiously once I exit color selection and it shows:

Wait, is that when the bulb is actually blue? If so, there's some problem with either reporting or parsing the reports from the device. "Hue: 0" is red, not blue (but could also just mean it's never got a report and that's some default), but "saturation: 0" would make any color white. I'd try commands from the device page directly to see if states update as expected; if not, the problem is with the device or driver, not the Dashboard.

Yup the bulb was brilliant blue. I've used both the Hubitat provided driver and the one from Inovelli with the same results.

Tried via driver commands. Set Blue via SET COLOR. Then went to SET SATURATION and selected 100 and the light went red.

Then I turned it off and back on and it quit doing that but here I turned it on and selected 3200 white. Then I changed the saturation and it turned to a green yellow color:

Also went to dashboard and tried changing it to blue from there. Initially it would not change then it did. Then tried changing to red but no response. Finally got it to do that. Then tried an off and it took about 10 seconds before it did anything and then a flurry of entries hit the log all at once with off being the last command.

On a different bulb I used the device page to set hue 64, level 33 and saturation 100. It took several attempts but finally set. Then I went to another bulb but when I looked to check that bulb the one I just set was now red and I never told it to be red. Here is the log from all of that:

Are these bulbs working for anyone else with the current Hubitat firmware? I have things to do now I'll try doing all this later with Inovelli's driver but yesterday when I was first running into this it didn't matter what driver I used.

I suppose it should be noted that Hubitat does not officially consider these compatible with the C-7. I think the only problem was when they were paired with S0, which with anything but the latest bulb firmware, they will do by default (unless you use a secondary controller). I have a couple paired like this (C-7, no security) and haven't noticed anything, but the bulbs in the basement and I don't use them much.

Have you verified that yours aren't paired with S0? Settings > Z-Wave Details is probably the easiest place to check.

They are as I could not for the life of me get them to pair as no security. I'll go check with the Inovelli people and see what they might offer.

Sigh....

There is a beta firmware update that should allow non-secure pairing with a special sequence. I just used a secondary controller (it was before they released this), which is handy with a C-7 in any case, but the above should work if you don't have one.

Ya I have the bulbs on that firmware but I still can't get them to pair with no security. I'll try again when I get some time.

The behavior seems to have changed (for the better) with the 2.2.9 hub firmware on a C7. This is with a bulb from Inovelli's recent batch with 2.31 bulb firmware, plus their current (Oct 2021) driver from github.

With this combination the bulb successfully paired secure first time, and both the device pane and the dashboard appear to set the bulb properly, and persist the values (including hitting 'x' on the dashboard and going back in). I tried switching between RGB & white modes, turning the bulb on/off, changing level and all worked properly.

I did notice the dashboard icon shows only the RGB color, regardless of whether RGB or white mode is active for the bulb, but that seems more like a quirk in the dashboard, not something specific to the bulb.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.

Download the Hubitat app