Inovelli LED Mini Dashboard App cant find my switch

I had previously used Rule Machine to make the LED notification on my Inovelli Red Fan/Light switch. I was having issues and started fresh.

I came upon the LED Mini Dashboard app by @jonathanb and figured that might be a better solution. I installed the app via Package Manager.

When I open the app and go to select my switch, it is not listed as an option. I checked to make sure I have the most up-to-date driver and I am. I double checked that I have the correct switch and I do (I even tried clicking through other switch options without any success).

Any ideas how to locate my switch?


Hub: C8

Are you using the driver provided by Inovelli instead of the HE built-in driver? I believe you need to use the Inovelli drivers in order for the app to recognize the switches. They can be installed via HPM.

I have the HE drivers installed... (Gen 2) per HPM

@jonathanb ?

I don't think fan switches are supported - pretty sure it's just the 2-1 switches.

Unfortunately, Jonathan hasn't been around in the community here for a while now, but hopefully he's OK and plans to return sometime.

If not, perhaps another community developer can pick this project up -- since fan switches are out, and the mmWave switches are coming, this would be a great app to keep active.

It does support the Red series fan/light switches. I use it with mine. I have version 1.13 installed.

1 Like

My dimmer stopped working so I found a newer driver to get them working again, I believe it is a beta, so there is nothing about notifications in it. I removed the switches as the notifications were not working. I tried to add them back and they are no longer found. What driver are you using?

It's not clear who you are asking this question to... What Inovelli switch do you have, and what driver are you currently using for it?

I am using the Inovelli VZW31-SN Red Series Z-Wave 2-in-1 Dimmer

I am using the driver from Inovelli Inovelli Driver

This weekend my C8 hub updated to, which caused my dimmer to no longer turn on or off, either remote or local. Commands were being sent to it, it just was not responding to any commands to turn on, off, or dim. I installed the above-linked driver, factor reset the switch, which I read about on another post, and used the replace feature to bring it back in. It is now functioning as a light and a dimmer. There are some issues with some of the settings, and there are no longer notifications to setup or change in the device. I have removed the 3 VZW31-SN dimmers from Led Mini Dashboard, and can not add them back. I could change the driver to the old one and see if they show back up, but I have not had time to. Lights in our kitchen are a bit more important than beta testing.

My question was to anyone having issues with the App not finding the switch.

Hopefully, you have some valuable insight to help us fix this issue.

I only use Blue 2-1s, so I unfortunately don't have any experience with the Reds. Hopefully a fellow Red user may be able to shed helpful light here.