Inovelli Black Series buttons not working

I just bought 4 Inovelli black series switches. I got them installed and paired, and I can control some functions via the device's Hubitat screen - i.e. I can change the notification LED color successfully, so I know it's connected. I have the relay turned off, because it's connected to Zigbee bulbs. I basically just wanted it "hard wired" so the switch would always send power to the bulbs. Essentially, I want the switch to act as 2 z-wave buttons to operate Zigbee bulbs.

So everything works except the buttons. When I press one on any switch, I get the following error in the logs:

org.codehaus.groovy.runtime.metaclass.MissingMethodExceptionNoStack: No signature of method: user_driver_InovelliUSA_Inovelli_Dimmer_LZW31_735.hold() is applicable for argument types: (java.math.BigDecimal) values: [1]
Possible solutions: poll(), off(), on(), find(), find(groovy.lang.Closure), wait() (hold)

Has anyone else run into this issue with Inovelli drivers? It's the official driver, so I figured it would be pretty flawless... Guess not.

To be clear, you see this error when physically pressing a button on the switch? Also, I think they were going to add button events (Z-Wave central scenes, technically) to physical presses on the Black Series but know the original firmware didn't do this, so knowing your firmware version may also be helpful. I don't see anything with this in their current driver, so I suspect this is still a to-do item. (The Red Series supports multi-taps and send scenes for all; the Black only supports one tap but, again, only send on/off and not scenes for that tap, at least at the moment.)

Well, I don't see that error anymore when doing it. I didn't see the logs before in real time, though. The times I reviewed seemed to coincide with when I pressed the button. But I don't know what to say, because it isn't happening anymore. Rather, nothing happens. The switches are still connected - I can set the notification LED color still. I'm not seeing anything in the log when I press the button (both info and debug logs are turned on permanently until I figure this out).

I totally would have spent the extra bucks for the red series, but none were available. The black series were in stock, and looked like they would still do all I really needed and more, so I just went for those instead. Hopefully that wasn't a mistake.

Yeah, the only thing I can think of that would cause this if you tried to run a "hold" command on the device from some app that expected these commands to be available (I can think of a couple that expect "push"--not sure about this one) or if you were using a Red Series driver (which obviously wouldn't work with full functionality on this device but would put commands like "held" in the UI, which will fail with that driver--on either Black or Red--last time I checked since Hubitat recently updated their button capabilities to require these commands, but their driver didn't implement them last I saw).

Black Series shouldn't be a mistake unless you need multi-taps or scene events. You might need the latter, but again, I think they were also planning to address that. If the on/off events from the switch are enough--which with the Black Series would basically correspond to a tap up or down, as long as it works--then that would probably be good enough as-is.

I disabled the internal relay, and it seems to disable the button altogether. I was hoping to turn off the internal relay so that power always flows to the RGB smart bulbs that are on the circuit. Then I was thinking the button would still be available to use, and planning on using the button to make a rule in Hubitat to turn on the RGB bulbs. But I am thinking this isn't possible with black series switches/dimmers.

I've got firmware 1.48, by the way (newest). It's it possible to "hack" the driver? Not sure I'm up for that, but maybe if it's possible... I've been known to do such kind of things. :slight_smile:

Otherwise, I guess I'll be returning these and waiting on the red series.

Thank you for the comments and suggestions!

Ah, yeah, with local control disabled on these, you won't get the on/off events, and with the current production firmware on these, you won't even get the scene (button) events for taps, either. I do believe they are aiming to address that second thing with a future device firmware update. Do you have the switch (LZW30) or dimmer (LZW31)? If you have the latter, it looks like beta firmware 1.49 should have actually added the scene events for single taps (and there are even a few newer versions than that now):

If you're using the switch (LZW30), then I don't see anything for that at the moment, but I might be missing something, or maybe it's still in the plans. (But since the firmware version you mentioned looks like a dimmer and not a switch, hopefully that is what you have.)

So, if you can, that's probably what I'd do. Otherwise, "unofficially" (with these or with other brands that don't support disabling local control at all...cough, cough, HomeSeer), some people literally hardwire the switch to be always on--i.e., line and load connected--so it still sends on/off events but can't actually modify the load. This may or may not be to code in your area or be (un)desirable for other reasons, but from a bulb standpoint, it would work.

Thank you so much, @bertabcd1234! That is incredibly helpful. I picked up a Z-wave stick to program the firmware (I have a C5, so no firmware updater inside Hubitat). I will give that a shot.

And if that doesn't do what I am looking for, I'm going to do exactly what you mentioned and hardwire the lights on. Will the switch still work with only the neutral and ground connected to it?

The switch needs line, neutral, and ground, but it doesn't need load, if that's what you're asking. (The official docs don't actually say this, but I did it when I was testing and it was fine--if it's not a no-neutral dimmer setup, I haven't seen any device where it actually does matter, so not too surprising. But I suppose there could still be something...)

1 Like

I think I'm getting very close to doing what I'd like to do. I updated the firmware to the latest beta firmware for the dimmer, v1.52. I can now put the switch in "smart bulb more" and the switch doesn't cut power to the lights anymore, even when you click the "off" (down) button.

I am trying to get the buttons to work correctly, but running into some unexpected behavior. In the Button Controllers app, I am able to select the device, but when it comes to picking a button, there is nothing that shows in the drop-down. So, I went the slightly more difficult route and tried to use Simple Automation Rules to create two rules - turn on when button 2 (up) pressed, turn off when button 1 (down) pressed. However, the button actions aren't detecting as I'd expect.

When I press up, the following is logged and the light turns on:
Switch - Hallway Lights: CentralSceneNotification(keyAttributes:2, sceneNumber:2, sequenceNumber:58)

But when I press down, the following is logged and nothing happens - action does not fire:
Switch - Hallway Lights: CentralSceneNotification(keyAttributes:0, sceneNumber:1, sequenceNumber:57)

When I use my other button controllers, I get a totally different message logged. It says "button 1 was pressed," for example. I do not get the "button 1 pressed" log event with the Inovelli switch, though. Instead, it's a scene notification as shown above. I'm not sure how to use this event as a trigger, though.

I'm also unsure how I've got one of the buttons triggering an event, but not the other one. They are both configured the same (just different button number), but only the up/on button works. Is there a different way to configure these button triggers that I am unaware of? I have probably 5 or so button remotes throughout the house and have not run into this before.

What driver are you using for these? I doubt that Hubitat's built-in driver supports button events for these, as the device (as you know) didn't originally support Z-Wave Central Scenes, and I don't think the driver has been modified since it's introduction. Inovelli's driver was updated a while back to provide them (though, of course, only if you are on sufficiently new firmware, as you are): Hubitat/inovelli-dimmer-lzw31.groovy at master · InovelliUSA/Hubitat · GitHub

@bertabcd1234 - thank you! That new driver did the trick!