innoveli/hubitat/zigbee smart bulb = headache

i have the innoveli [Lzw31-sn] gen 2 switch running on firmware 1.48.
my hubitat is harware rev c5 with version
i have linkind tunable white zigbee smart bulbs

the innoveli switch is hardwired to control my linkind zigbee bulbs and both the bulnb and switch is connected to my hubitat

smart bulb mode is on in the hubitat inovelli page (parameter 52)
i attempted to try with disable local control both on and off
i used both rule machine and button controllers to attempt to control the lights with no luck
with disable local control on i can hard control the bulbs on and off (directly giving power which is not the goal because they are smart lights)

my goal is to be able to control the smart bulbs to turn on/off and dim with the innoveli switch (eventually changing the color temperature if i can achieve the dimming)

no matter what i do, the switch either does not work, because local control is disabled, or cut power off directly when local dimming is enabled

im pretty confident in using both rule machine and button controllers because i was able to program lutron picos to do the same thing for another room with the same smart bulbs.
can anyone give me a solution in what i am doing wrong, or is the innoveli switch not capable of what i have in mind

Your connections are not 100% clear.

However you might try this:

This setting will force the output to stay on 100% of the time regardless of manual or Z-Wave command. It is used then the dimmer is powering a smart bulb and the owner wants to control the bulb via the dimmer paddle or Hub command.

I might have an old manual so you should check if this has changed. This manual has no parameter 52.

I have recently done the same thing you are attempting and it was a bit of work, but it functions properly now. Some things to look for:

1. Both the switch and the bulb must be paired at the same security level (none would be best)
2. The switch should be updated to the latest beta firmware if you want to enable “Smart Bulb” mode in a way that remains on all the time
3. The switch has a “Smart Bulb” mode which you should enable to ensure it remains on (using Inovelli community driver - not sure about the built-in driver)
4. Enable Association Groups 2, 3 and 4

Looks like the smart bulbs are Zigbee, so security and association groups won't matter (but that's a good option if you're using Z-Wave bulbs!). Once you disable local control as @JohnRob suggested (either 8x on the config button or the preference in Inovelli's driver can toggle this), the dimmer basically becomes a button device, and you should be able to program it in a similar way to whatever you did with the Pico. The biggest difference will be that if you're using Inovelli's driver, the button events/names may be wildly different from what you expect. There's a chart somewhere, but looking at the logs as you press, hold, and release may give you the best idea of what's happening. Or, Hubitat's built-in driver, if you're using that, uses more conventional button events, but it maxes out at 2 taps, which lots of people don't like.

1 Like

Oh! I read the description too quickly…. Thanks for the correction!

thank you for the response. my switch already had version 1.48 but i will try the 1.48 beta which is the latest. their was already an option for smart bulb mode for my switch

parameter 52 is for enabling your switch for smart bulb use. I've tried that via the parameters in hubitat as well as pressing 8 times.

thanks for the response, I'm using the newest drivers provided by innoveli, I'm using just 1 push/held press to verify that it works i get no response, even when trying to control other smart devices in my house.

What do you see in the logs when this happens? With info and debug logging enabled, you should see some "CentralScene" log entry for taps, holds, and releases (if you don't see this, something is wrong--the switch isn't sending them) and some info log about a button event like "button x was pushed/held/released" (or an actual event on the "Events" button/tab on the device page, which you can check as an authoritative source after the fact too).

i cant send screenshots to show you whats going on. but the button press states do not update regularly

so, i just did a factory reset and now everything seems to be working now. i honestly dont know what fixed it but its so far working