Including Zwave Devices


New to HE not HA :slight_smile:

I am trying to add a zwave thermostat, the other 9 identical ones all included Ok but I am having issues with them

This one I am getting

and it just stays there stuck...

Have tried multiple times no joy -

Any ideas/ Suggestions - will try an HE reboot first

If you go to the Devices page do you see it there? If so, may want to try hitting Configure and saving.

1 Like

Another thing to look out for are ghost devices which can remain if the pairing didn’t properly complete. If you have a C-7 hub, you can get this information in the z-wave details screen. Look for devices that don’t have any information under the cluster column other than in: and out:.

Those ghost devices will cause issues in your Z-Wave mesh.


Managed to remove it by forcing an exclude


how do i force exclude a ghost device?

@robertrgarner3, to force exclude a ghost device within the C7 hub, you need to go to the Z-Wave Details screen and then at the device, click on "Remove" or if that isn't an option, click on "Refresh" until it is.

You may need to power-off the device that triggered the creation of a ghost. This will typically be the next device in the list.

If you have a UZB stick, it is very easy to remove a ghost with it. I had some ghost problems and was able to remove all but one. I got a UZB stick from and it worked with one click.

Oh, and welcome to the community!

1 Like

thanks for the help, sebastien.

for posterity sake, here is what happened, and what i did to fix it:

i attempted to add a door sensor several times without success. so i decided to save that particular device for later, and moved on to the next device to add. but every time i tried to add a device the ghost device would show up. finally i figured out that it was the door sensor, so i excluded that sensor and the ghost went away.

also for the sake of posterity, "remove" was not an option on the z-wave details screen.

1 Like